<!-- html-header type=current begin -->
	
	<!DOCTYPE html>
	
	<html lang="en">
	<head>
	<!-- Render IE9 -->
	<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">

	


	<script id="before-content" type="text/javascript">
(function () {
    if (typeof window.sdmedia !== 'object') {
         window.sdmedia = {};
    }
    if (typeof window.sdmedia.site !== 'object') {
        window.sdmedia.site = {};
    }

    var site = window.sdmedia.site;
    site.rootdir = "//slashdot.org";
}());

var pageload = {
	pagemark: '734901460387201111',
	before_content: (new Date).getTime()
};
function pageload_done( $, console, maybe ){
	pageload.after_readycode	= (new Date).getTime();
	pageload.content_ready_time	= pageload.content_ready - pageload.before_content;
	pageload.script_ready_time	= pageload.after_readycode - pageload.content_ready;
	pageload.ready_time		= pageload.after_readycode - pageload.before_content;
	// Only report 1% of cases.
	maybe || (Math.random()>0.01) || $.ajax({ data: {
		op: 'page_profile',
		pagemark: pageload.pagemark,
		dom: pageload.content_ready_time,
		js: pageload.script_ready_time
	} });
}
</script>
	<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1"> 
	
		<title>Vulnerabilities Discovered In Mobile Bootloaders of Major Vendors - Slashdot</title>
		<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
	
		<meta name="description" content="An anonymous reader writes: Android bootloader components from five major chipset vendors are affected by vulnerabilities that break the CoT (Chain of Trust) during the Android OS boot-up sequence, opening devices to attacks. The vulnerabilities were discovered with a new tool called BootStomp, deve...">
		<meta itemprop="name" content="Vulnerabilities Discovered In Mobile Bootloaders of Major Vendors - Slashdot">
		<meta itemprop="description" content="An anonymous reader writes: Android bootloader components from five major chipset vendors are affected by vulnerabilities that break the CoT (Chain of Trust) during the Android OS boot-up sequence, opening devices to attacks. The vulnerabilities were discovered with a new tool called BootStomp, deve...">
	
	
		<meta property="fb:admins" content="100000696822412">
		<meta property="fb:page_id" content="267995220856">
	
		<meta name="viewport" content="width=1000, user-scalable=yes, minimum-scale=0, maximum-scale=10.0" />
		<meta name="apple-mobile-web-app-capable" content="yes">
		<meta name="apple-mobile-web-app-status-bar-style" content="black">
	
		<meta property="og:image" content="https://a.fsdn.com/sd/topics/android_64.png">
	
	
		<link rel="canonical" href="https://mobile.slashdot.org/story/17/09/05/0257221/vulnerabilities-discovered-in-mobile-bootloaders-of-major-vendors">
		
		<link rel="alternate" media="only screen and (max-width: 640px)" href="http://m.slashdot.org/story/330841" >
	

		<link rel="stylesheet" type="text/css" media="screen, projection" href="//a.fsdn.com/sd/classic.ssl.css?1f8cff0f988a8983" >
		<!--[if IE 8]><link rel="stylesheet" type="text/css" media="screen, projection" href="//a.fsdn.com/sd/ie8-classic.ssl.css?1f8cff0f988a8983" ><![endif]-->
		<!--[if IE 7]><link rel="stylesheet" type="text/css" media="screen, projection" href="//a.fsdn.com/sd/ie7-classic.ssl.css?1f8cff0f988a8983" ><![endif]-->
	
	
	



	
	<!--  -->

	
	

	
	<!-- SMACKS: NEW CSS -->
	<link rel="stylesheet" href="//a.fsdn.com/sd/css/app.css?1f8cff0f988a8983">

	<script type='text/javascript'>
var _gaq = _gaq || [];
</script>





         
   
   

<script type="text/javascript" id="pbjs_script" data-dom="https://d3tglifpd8whs6.cloudfront.net"  src="https://d3tglifpd8whs6.cloudfront.net/js/prebid/slash-story/slash-story.min.js"></script>
<script type='text/javascript'>
    /*global performance */
    var googletag = window.googletag || {};
    googletag.cmd = googletag.cmd || [];
</script>

<!-- prep GPT ads -->
<script type='text/javascript'>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</script>



<!-- CrossPixel -->
<script type="text/javascript"> try{(function(){ var cb = new Date().getTime(); var s = document.createElement("script"); s.defer = true; s.src = "//tag.crsspxl.com/s1.js?d=2397&cb="+cb; var s0 = document.getElementsByTagName('script')[0]; s0.parentNode.insertBefore(s, s0); })();}catch(e){} </script>

<!-- Magnetic -->
<script type="text/javascript">
  // FHItem-toptags: 
  
  var backend_tpc = [[ "mobile", "privacy", "security", "android" ]] || ['information technology','tech'];
  var mag_keywords = backend_tpc.join(",");
  mag_keywords = ( mag_keywords.length > 0 ? mag_keywords : 'information technology,tech' );
  //console.log("mag.keywords: " + mag_keywords );
  /* Version: 0.7 */
  /* <![CDATA[ */
  try {
  var _mag = _mag || {};
  _mag.kw = mag_keywords;
  _mag.kw_encoded = 0;
  _mag.shortName = 'sourceforgemedia-computing';
  _mag.default_protocol = ('https:' == document.location.protocol ? 'https:' : 'http:');
  _mag.startTime = (new Date()).getTime();
  (function(d,t) {
  var mag = d.createElement('script'); mag.type = 'text/javascript'; mag.async = true; mag.src = t;
  var head = d.getElementsByTagName('head')[0] || d.documentElement; head.insertBefore(mag, head.firstChild);
  })(document,  _mag.default_protocol + '//d3ezl4ajpp2zy8.cloudfront.net/sourceforgemedia-computing_tag.js');
  } catch (e) {}
  /* ]]> */
</script>

<!-- AdBlock Check -->
<script>
var isAdBlockActive = true;
</script>
<script async src="//a.fsdn.com/sd/js/scripts/ad.js?1f8cff0f988a8983"></script>

</head>
<body class="anon firehose ">

	
	<script src="//a.fsdn.com/sd/all-minified.js?1f8cff0f988a8983" type="text/javascript"></script>
	
	
	<script type="text/javascript">
(function(){
var regexp=/\s*(?:\d+|many)\s+more\s*/i;

	
	var auto_more_count = 1;

	function auto_more(){
		var $more_link = $('#more-experiment a');
		$more_link.each(function(){
			var $lastitem = $('#firehoselist>article.fhitem:visible:last');
			if ( Bounds.intersect(window, $lastitem) ) {
			
			
				!--auto_more_count && (auto_more=undefined);
				// don't allow a call till the next paginate gets built and |more_possible|
				$(document).unbind('scroll', call_auto_more);
			}
		});
	};

	function call_auto_more(){ auto_more && auto_more(); }
	

$('#more-experiment a').
	live('more-possible', function( event ){
		var $more_link=$(this);
		if ( regexp.test($more_link.text()) ) {
		
			$(document).bind('scroll', call_auto_more);
		} else {
			$(document).unbind('scroll', call_auto_more);
		
		}
	});
})();
</script>
	<!--[if lt IE 9]><script src="//a.fsdn.com/sd/html5.js"></script><![endif]-->
	
	
	<script type="text/javascript">
		(function() {
			if (typeof window.janrain !== 'object') window.janrain = {};
			if (typeof window.janrain.settings !== 'object') window.janrain.settings = {};

			/* _______________ can edit below this line _______________ */

			janrain.settings.tokenUrl = 'https://slashdot.org/token_callback.pl';
			janrain.settings.type = 'embed';
			janrain.settings.appId = 'ggidemlconlmjciiohla';
			janrain.settings.appUrl = 'https://login.slashdot.org';
			janrain.settings.providers = [
			'googleplus',
			'facebook',
			'twitter',
			'linkedin'];
			janrain.settings.providersPerPage = '5';
			janrain.settings.format = 'one column';
			janrain.settings.actionText = 'Sign in with';
			janrain.settings.showAttribution = false;
			janrain.settings.fontColor = '#666666';
			janrain.settings.fontFamily = 'lucida grande, Helvetica, Verdana, sans-serif';
			janrain.settings.backgroundColor = '#ffffff';
			janrain.settings.width = '300';
			janrain.settings.borderColor = '#cccccc';
			janrain.settings.borderRadius = '5';    janrain.settings.buttonBorderColor = '#CCCCCC';
			janrain.settings.buttonBorderRadius = '0';
			janrain.settings.buttonBackgroundStyle = 'gray';
			janrain.settings.language = '';
			janrain.settings.linkClass = 'janrainEngage';

			/* _______________ can edit above this line _______________ */

			function isReady() { janrain.ready = true; };
			if (document.addEventListener) {
			  document.addEventListener("DOMContentLoaded", isReady, false);
			} else {
			  window.attachEvent('onload', isReady);
			}

			var e = document.createElement('script');
			e.type = 'text/javascript';
			e.id = 'janrainAuthWidget';

			e.src = 'https://rpxnow.com/js/lib/login.slashdot.org/engage.js';

			var s = document.getElementsByTagName('script')[0];
			s.parentNode.insertBefore(e, s);
		})();
	</script>
	
		<script src="//cdn-social.janrain.com/social/janrain-social.min.js"></script>
		<script type="text/javascript">
			(function($) {
				$(function(){
					janrain.settings.appUrl = "https://login.slashdot.org";
					$twitter = $('body .janrain_twitterButton');
					$twitter.append('<i class="icon-twitter"></i>');

					janrain.settings.social = {
						providers: [
							"facebook",
							"twitter",
							"linkedin",
							"native-googleplus",
							"native-reddit"
						],
						shareCountMin: "100",
						shareCountMode: "combined"
					};
				});
			})($j);
		</script>
	<!-- index2_variant ||-->
	
	<!-- TABOOLA -->
	<script type="text/javascript">
	  window._taboola = window._taboola || [];
	  _taboola.push({home:'auto'});
	  !function (e, f, u) {
		e.async = 1;
		e.src = u;
		f.parentNode.insertBefore(e, f);
	  }(document.createElement('script'),
	  document.getElementsByTagName('script')[0],
	  '//cdn.taboola.com/libtrc/slashdot/loader.js');
	</script>
	
	<!-- html-header type=current end --><!-- header type=current begin -->
	
	
	
	<link rel="top"       title="News for nerds, stuff that matters" href="//slashdot.org/" >
<link rel="search"    title="Search Slashdot" href="//mobile.slashdot.org/search.pl">
<link rel="alternate" title="Slashdot RSS" href="http://rss.slashdot.org/Slashdot/slashdotMain" type="application/rss+xml">
	<link rel="shortcut icon" href="/favicon.ico" type="image/x-icon">

	
		<div id="top_parent"></div>
		<a name="topothepage"></a>
		
		<div class="container">
			<div class="nav-wrap">
				<nav class="nav-primary" role="navigation" aria-label="Global Navigation">
					<h1 class="logo">
	<a href="//slashdot.org"><span>Slashdot</span></a>
</h1>

<ul class="nav-site">
	<li><a href="//slashdot.org"><i class="icon-book" title="Stories"></i><span>Stories</span></a></li>
	<li>
		<ul class="filter-firehose">
			<li class="nav-label">Firehose <i class="icon-angle-right"></i></li>
			<li><a href="//slashdot.org/recent">All</a></li>
			<li><a href="//slashdot.org/popular">Popular</a></li>
		</ul>
	</li>
	<li><a href="//slashdot.org/polls"><i class="icon-chart-bar" title="Polls"></i><span>Polls</span></a></li>

	<!--
	<li><a href="//ask.slashdot.org"><i class="icon-question-circle"></i><span>Ask</span></a></li>
	
	<li><a href="//events.slashdot.org"><i class="icon-calendar"></i><span>Events</span></a></li>
	-->
	<li><a href="http://deals.slashdot.org/?utm_source=slashdot&amp;utm_medium=navbar&amp;utm_campaign=dealshp_1" target="_blank"><i class="sd-mini" title="Deals"></i> <span>Deals</span></a></li>
</ul>
<a href="//slashdot.org/submission" class="btn btn-success">Submit</a>
				</nav>
				<nav class="nav-user" role="navigation" aria-label="user access and account controls">
					<form id="search" class="form-inline nav-search-form" method="get" action="//slashdot.org/index2.pl">
<!-- //mobile.slashdot.org/index2.pl" -->
	<div class="form-group">
		<label class="sr-only" for="sitesearch">Search Slashdot</label>
		<div class="input-group">
			<input type="text" id="" class="" name="fhfilter" value="" placeholder="Search">
		</div>
	</div>
	<button type="submit" class="btn icon-search"></button>
</form>
<ul class="user-access">
	
		
			<li >
				<a href="//slashdot.org/my/login"  onclick="show_login_box(); return false;"><i class="icon-login"></i><span> Login</span></a>
				
			</li>
		
	
		
			<li class="nav-label">or</li>
		
	
		
			<li >
				<a href="//slashdot.org/my/newuser"  onclick="getModalPrefs('newUserModal', 'Create Account', 1); $('#modal_box').addClass('join'); return false;"><i class="icon-user-add"></i><span> Sign up</span></a>
				
			</li>
		
	
</ul>
				</nav>
			</div>
			<div class="nav-secondary-wrap">
				<nav class="nav-secondary" role="secondary-navigation">
	<ul>
		<li class="nav-label">Topics: </li>
		<li><a href="//devices.slashdot.org">Devices</a></li>
		<li><a href="//build.slashdot.org">Build</a></li>
		<li><a href="//entertainment.slashdot.org">Entertainment</a></li>
		<li><a href="//technology.slashdot.org">Technology</a></li>
		<li><a href="//slashdot.org/?fhfilter=opensource">Open Source</a></li>
		<li><a href="//science.slashdot.org">Science</a></li>
		<li><a href="//yro.slashdot.org">YRO</a></li>
		<!-- <li><a href="//slashdot.org/topics.pl">more...</a></li> -->
	</ul>
</nav>
<nav class="nav-social" role="social navigation">
	<ul>
		<li class="nav-label">Follow us:</li>
		<li><a href="http://rss.slashdot.org/Slashdot/slashdotMain" target="_blank"><i class="icon-rss-squared"></i><span class="sr-only">RSS</span></a></li>
		<li><a href="http://www.facebook.com/slashdot" target="_blank"><i class="icon-facebook-squared"></i><span class="sr-only">Facebook</span></a></li>
		<li><a href="https://plus.google.com/112601993642376762846/" target="_blank"><i class="icon-gplus-squared"></i><span class="sr-only">Google+</span></a></li>
		<li><a href="http://twitter.com/slashdot" target="_blank"><i class="icon-twitter-squared"></i><span class="sr-only">Twitter</span></a></li>
		<li><a href="//slashdot.org/newsletter" target="_blank"><i class="icon-mail-squared"></i><span class="sr-only">Newsletter</span></a></li>
	</ul>
</nav>
			</div>
		</div>

		<section>
		
			<div class="message-bar" id="firehose-message-tray">
				<span class="icon-quote-left"></span>
				<p>
					
						
						Slashdot is powered by <strong><a href="//mobile.slashdot.org/submission">your submissions</a></strong>, so send in your scoop
					
				</p>
			</div>
		
		
			<div id='embbeded_login_modal' class="hide">
<form action="https://slashdot.org/my/login" method="post" onsubmit="if (global_returnto) { this.returnto.value = global_returnto }" class="embedded"><fieldset style="-webkit-border-radius:10px 10px 0 0;border-radius:10px 10px 0 0;-moz-border-radius:10px 10px 0 0">
<div style='height:25px;'>&nbsp;</div>
    <input type="hidden" name="returnto" value="">
    <input type="hidden" name="op" value="userlogin">
    <p>
        <label class="fleft" for="unickname">Nickname:</label>
        <input type="text" name="unickname" value="">
    </p>
    <p>
        <label class="fleft" for="upasswd">Password:</label>
        <input type="password" name="upasswd" placeholder="6-20 characters long">
    </p>
    <label class="checkbox"><input type="checkbox" name="login_temp" value="yes"> Public Terminal</label>
    <br>
    <hr>
    <input type="submit" name="userlogin" value="Log In" class="fno"> <a href="//slashdot.org/my/mailpassword" class="btn link" onclick="getModalPrefs('sendPasswdModal', 'Retrieve Password', 1); return false;">Forgot your password?</a>
</fieldset></form>

<div id="janrainEngageEmbed"></div>
<div class="actions">
 <a class="ico close" onclick="hide_login_slider();" href=""><span>Close</span></a>
</div>
</div>
		
		
			<div class="banner-wrapper">
				<div class="adwrap adwrap-unviewed banner-contain">
					
					<div id='div-gpt-ad-728x90_a'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-728x90_a');});</script></div>
					<div id='div-gpt-ad-hubicon_200x90_a'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-hubicon_200x90_a');});</script></div>
				</div>
			</div>
		
		<a name="main-articles"></a>
	
	<!-- header type=current end --><!-- body begin -->







	

	<style type="text/css">
menu, menu * {
	text-decoration:none;
}

menu[type=context] {
	display:none;
	position:absolute;
	z-index:10000;
}

menu[type=context]:not(.brief) {
	background-color:#dfdfdf;
	margin:0;
	padding:2px 0.5em;
	border-style:solid;
	border-width:1px;
	border-color:#eeeeee #aaaaaa #aaaaaa #eeeeee;
	-moz-border-radius-topright:.7em;
	-webkit-border-top-right-radius: 0.7em 0.7em;
}

menu.full[type=context] > a.slash-hover:first-child {
	-moz-border-radius-topright:.6em;
	-webkit-border-top-right-radius: 0.6em 0.6em;
}



menu.brief[type=context] > a {
	-moz-border-radius:.6em;
	-webkit-border-radius: 0.6em;
	color:#ffffff;
	background-color:#000000;
}

/*
span.briefmenu a.tag:not(.datatype) {
    padding-left:.5em;
}
*/




/* #tag-menu a, #feedback-menu a  { */
menu.tag-menu-admin a {
	display:list-item;
	list-style:none;
	text-align:left;
	font-weight:bold;
	color:black;
	padding:0.1em 0.5em;
	margin:-0.1em -0.5em;
	cursor:pointer;
}


.tags .edit-bar { position:relative; }
article aside .share .addthis_toolbox { display:block; width:60px; float:left; }
article aside.view_mode .share { min-width:120px; padding-top:.5em; }
#firehose.list article header h2 {padding-left: 20px; !important}
.novote .vote { display:none; }

.vote > a, .votedup > a, .voteddown > a {
	display:inline-block;
	height:22px;
	width:22px;
	margin: 2px 10px 0 0;
	color:rgb(255,255,255);
	text-decoration:none;
	line-height:22px;
	text-align:center;
	font-weight:bold;
	font-size:14px;
	border-width:1px;
	border-style:solid;
	border-color:rgba(0,0,0,0.5);
}

.vote > a, .votedup > a, .voteddown > a {color:rgb(0,0,0);}

article.fhitem-submission h2 .vote > a, article.fhitem-submission h2 .votedup > a, article.fhitem-submission h2 .voteddown > a { border-color:rgba(0,0,0,0.15); }
.vote .up, .vote .down, .votedup .up, .votedup .down, .voteddown .up, .voteddown .down { border-radius: 4px; -moz-border-radius: 4px; -webkit-border-radius: 4px; /* text-shadow:0 0 2px #000000; }*/}
article:not(.fhitem-story) .vote .up,article:not(.fhitem-story) .vote .down,article:not(.fhitem-story) .votedup .up,article:not(.fhitem-story) .votedup .down,article:not(.fhitem-story) .voteddown .up,article:not(.fhitem-story) .voteddown .down { /*text-shadow:none !important; */}
.voteddown .down, .votedup .up { margin-right: 10px; text-indent:2px; line-height:24px; }
article:not(.fhitem-story) .votedup .up,article:not(.fhitem-story) .voteddown .down {background: rgb(174,174,174);background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(rgb(174,174,174)), to(rgb(193,193,193)));background-image: -moz-linear-gradient(100% 100% 90deg,rgb(193,193,193), rgb(174,174,174) 100%);color:rgb(0,0,0);}
article.fhitem-story .votedup .up,article.fhitem-story .voteddown .down {background: rgb(0,66,66);background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(rgb(0,53,53)), to(rgb(0,102,102)));background-image: -moz-linear-gradient(100% 100% 90deg,rgb(0,102,102), rgb(0,53,53) 100%);}




#tag-menu span.var-tag {
font-weight:normal;
color:#444444;
}

menu.reasons-menu a {
padding:0 .25em 0 .25em;
font-size:80%;
-moz-border-radius:.5em;
-webkit-border-radius:.5em;
cursor:pointer;
}

menu.reasons-menu a:hover {
background:rgb(153,153,153);
background:-moz-linear-gradient(100% 100% 90deg, rgb(102,102,102), rgb(153,153,153) 70%) repeat scroll 0 0 rgb(102,102,102);
background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(rgb(153,153,153)), to(rgb(102,102,102)));
color:#fff;
text-decoration:none;
font-weignt:normal;
}

article.fhitem-story menu.reasons-menu a:hover {
background:#002323 !important;
background:-moz-linear-gradient(100% 100% 90deg, #002323, #005353 70%) repeat scroll 0 0 #002323 !important;
background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(#005353), to(#002323)) !important;
}


menu.reasons-menu {
	display:none;
	margin:0;
	padding:0;
}

div.fhitem h3 menu.reasons-menu {
margin:0.25em 0 0;
}

div.fhitem h3 menu.reasons-menu a.tag {
font-size:.8em;
}

#tag-menu a.slash-hover,
#feedback-menu a.slash-hover,

.tag-display span.tag:hover,
.tag-display span.tag.trigger {
	color:white;
	background-color:rgb(0, 85, 85);
}

#tag-menu a.slash-hover span.var-tag {
	color:#eee;
}

.tag-entry.default {
        color:#ccc;
}

.brief .nix {
	margin-top:-1.35em;
	margin-left:0px;
	margin-top:-1.15em;
	text-decoration:none;
	line-height:1.35em;
	padding:0 2px;
	-moz-border-radius:.6em 0 0 .6em;
	-webkit-border-radius:.6em 0 0 .6em;
	-o-border-radius:.6em 0 0 .6em;
	border-radius:.6em 0 0 .6em;
    color:#fff !important;
    background:transparent !important;
}

.brief .nix:hover {
    background:rgb(153,153,153) !important;
    background:-moz-linear-gradient(100% 100% 90deg, rgb(102,102,102), rgb(153,153,153) 70%) repeat scroll 0 0 rgb(102,102,102) !important;
    background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(rgb(153,153,153)), to(rgb(102,102,102))) !important;
}

</style>

<menu id="nix-reasons" style="display:none">
	<a class="tag">binspam</a><a class="tag">dupe</a><a class="tag">notthebest</a><a class="tag">offtopic</a><a class="tag">slownewsday</a><a class="tag">stale</a><a class="tag">stupid</a>
</menu>
<menu id="nod-reasons" style="display:none">
	<a class="tag">fresh</a><a class="tag">funny</a><a class="tag">insightful</a><a class="tag">interesting</a><a class="tag">maybe</a>
</menu>
<menu id="comment-nix-reasons" style="display:none">
	<a class="tag">offtopic</a><a class="tag">flamebait</a><a class="tag">troll</a><a class="tag">redundant</a><a class="tag">overrated</a>
</menu>
<menu id="comment-nod-reasons" style="display:none">
	<a class="tag">insightful</a><a class="tag">interesting</a><a class="tag">informative</a><a class="tag">funny</a><a class="tag">underrated</a>
</menu>

<menu id="tag-nod-reasons" style="display:none">
	<a class="tag">descriptive</a>
</menu>
<menu id="feedback-menu" class="tag-menu-admin" type="context">
	<a class="tag">typo</a><a class="tag">dupe</a><a class="tag">error</a>
</menu>
<menu id="tag-menu" class="tag-menu-admin none" type="context">

<!--	<a data-op="!" class="nix">!<span class="var-tag hide"></span></a>-->

</menu>

<script type="text/javascript">
$(function(){
var $CURRENT_MENU, $TAG_MENU=$('#tag-menu'), NOTNOT=/^!!/, IE7=/^7\.0/, TAG_PREFIX=/^\/tag\//;

function get_tag_name( $tag ){
	return ($tag.attr('href') || '').replace(TAG_PREFIX, '') || $tag.text().toLowerCase();
}

function trigger_menu( e, selector, $menu, menu_content ){
	var $target=$(original_target(e, selector)), in_use=$target.is('.trigger');
	if ( $CURRENT_MENU ) {
		$CURRENT_MENU.menu('cancel', e);
		$CURRENT_MENU = null;
	}

	if ( !in_use ) {
		menu_content && $menu.stop(true, true).hide().html(menu_content);
		($CURRENT_MENU=$menu).menu('context', e);
	}
	return !in_use;
}

function open_menu( trigger, $menu ){
	var $trigger=$(trigger), $fhitem=$trigger.closest('.fhitem');
	$fhitem.length && user_intent('interest', $fhitem[0]);

	$menu.appendTo(document.body).css({ opacity:0 }).show();

	var 	right	= $fhitem.offset().left + $fhitem.width(),
		global	= $trigger.offset(),
		local	= $menu.offsetParent().offset();

	// Ugly IE position hack required:
	$.browser.msie && IE7.test($.browser.version) && (local.top = 0);

	// pin the menu (horizontally) on-screen
	global.left = Math.min(global.left, right-$menu.width());

	$trigger.addClass('trigger');
	$menu.css({
		position:	'absolute',
		top:		global.top - local.top + $trigger.height(),
		left:		global.left - local.left,
		opacity:	1
	});
}

function close_menu( trigger, $menu ){
	$menu.hide();
	$(trigger).removeClass('trigger');
	($CURRENT_MENU===$menu) && ($CURRENT_MENU=false);
}

/* T2 tag context-menu */
var $TAG_MENU=$('#tag-menu'), NOTNOT=/^!!/;


    var user_is_admin = 0;



$('a[rel=tag]').live('mousedown',function(ea){
    window.open(this.href);
    return false;
})

$('.tag-bar .disagree').live('mousedown',function(ee){
	var fhitem = $(original_target(ee)).closest('.fhitem')[0],
		command = ('!' + $(original_target(ee)).attr("data-tag")).replace(NOTNOT, '');
    try { Tags.submit(fhitem, command); } catch ( err ) {  }
    return false;
})



$('a[rel=tag]').
	live('mousedown', function( e ){
        
            return true;
        

	}).
	live('click', function( e ){
		if ( !logged_in ) {
			var	target	= original_target(e),
				tag	= $(target).text();
			addfhfilter(tag);
		}
		e.preventDefault();
		return false;
	});

$TAG_MENU.menu({
	cssNamespace: 'slash',
	liveTriggers: true,
	clickDuration: 300,

	start: function( e, ui ){
		var	$tag	= $(ui.trigger),
			tag	= get_tag_name($tag),
			context	= firehose_settings && firehose_settings.viewtitle;

		// Insert the tagname into the menu items where needed.
		$TAG_MENU.find('span.var-tag').text(tag);
		$TAG_MENU.find('a.nix').attr('title','not ' + tag);


			// non-admins may only delete their own tags
		$TAG_MENU.find('a:[data-op="-"]').toggle($tag.is('.my'));
	

		// *tagname* in *viewtitle*
		$TAG_MENU.find('a:[data-op="="]').toggle(!!context);
		context && $TAG_MENU.find('span.var-view').text(context);

		open_menu($tag, $TAG_MENU);
	},

	select: function( e, ui ){
		var	$tag	= $(ui.trigger),
			tag	= get_tag_name($tag),
			op	= $(ui.select).attr('data-op'),
			fhitem,
			command;

		// Global for positioning other things.
		$related_trigger = $tag;

		switch ( op ) {
			case '=':
				addfhfilter(tag);
				break;

			default:
				fhitem = $tag.closest('.fhitem')[0];
				command = (op + tag).replace(NOTNOT, '');
				try { Tags.submit(fhitem, command); } catch ( err ) {  }
				break;
		}
	},

	stop: function( e, ui ){ close_menu(ui.trigger, $TAG_MENU); }
});




/* T2 feedback context-menu */



/* T2 datatype context-menu (admin-only) */






});
</script>

	

<!-- SMACKS: BEGIN STORY CONTENT -->
<div class="container">
	<!--SMACKS: BEGING CENTER COLUMN -->
	<div class="main-wrap has-rail-right">
		<div class="main-content">
			<div class="grid_24 a2 ">
			</div>
			<div id="firehose" class="nothumbs">
			<div id="firehoselist" class="fhroot fleft  grid_24">
				<div id="announcement">
 <strong><a href="https://slashdot.org/newsletter">Sign up for the Slashdot Daily Newsletter!</a></strong><br><strong>DEAL:</strong> For $25 - <strong><a href="http://hshd.io/nuLx" rel="nofollow" target="_blank">Add A Second Phone Number To Your Smartphone for life! Use promo code SLASHDOT25.</a></strong>
  <a href="" class="btn-close" title="don't show me this again" onclick="closeAnnouncement(); return false;">&times;</a>
</div>


<script type="text/javascript">

if (!$.cookie('hide_sitenotice_36')) {
	$('#announcement').fadeIn(300);
}

function closeAnnouncement() {
	$('#announcement').fadeOut(300);
	$.cookie('hide_sitenotice_36', 'true', { path: '/', domain: 'slashdot.org', expires: 28 });
}
</script>
				<article id="firehose-93472087" data-fhid="93472087" data-fhtype="story" class="fhitem fhitem-story article usermode thumbs grid_24">
		<span class="sd-info-block" style="display: none">
			<span class="sd-key-firehose-id">93472087</span>
			<span class="type">story</span>
			
		</span>







	
	

<header>
	
		<span class="topic" id="topic-93472087">
			<a href="//mobile.slashdot.org/index2.pl?fhfilter=android" onclick="return addfhfilter('android');">
			
				<img src="//a.fsdn.com/sd/topics/android_64.png" width="64" height="64" alt="Android" title="Android">
			
		</a>
		
	
		
		
		
		

		
		<a href="//mobile.slashdot.org/index2.pl?fhfilter=privacy" onclick="return addfhfilter('privacy');">
			
				<img src="//a.fsdn.com/sd/topics/privacy_64.png" width="64" height="64" alt="Privacy" title="Privacy">
			
		</a>
		
	
		
		

		
		<a href="//mobile.slashdot.org/index2.pl?fhfilter=security" onclick="return addfhfilter('security');">
			
				<img src="//a.fsdn.com/sd/topics/security_64.png" width="64" height="64" alt="Security" title="Security">
			
		</a>
		</span>
	

	<h2 class="story">
		

		

		
		

		

		

		

		<span id="title-93472087" class="story-title"> <a   href="//mobile.slashdot.org/story/17/09/05/0257221/vulnerabilities-discovered-in-mobile-bootloaders-of-major-vendors">Vulnerabilities Discovered In Mobile Bootloaders of Major Vendors</a> <span class=" no extlnk"><a class="story-sourcelnk" href="https://www.bleepingcomputer.com/news/security/vulnerabilities-discovered-in-mobile-bootloaders-of-major-vendors/"  title="External link - https://www.bleepingcomputer.com/news/security/vulnerabilities-discovered-in-mobile-bootloaders-of-major-vendors/" target="_blank"> (bleepingcomputer.com) </a></span></span>

		
		
		<!--<span class="comments commentcnt-93472087" >61</span>-->
		

		
		<!-- comment bubble -->
		
			<span class="comment-bubble"><a href="//mobile.slashdot.org/story/17/09/05/0257221/vulnerabilities-discovered-in-mobile-bootloaders-of-major-vendors#comments" title="">61</a></span>
		
	</h2>
	<div class="details" id="details-93472087">
		<span class="story-details">
		<span class="story-views">
			<span class="sodify" onclick="firehose_set_options('color', 'red')" title="Filter Firehose to entries rated red or better"></span><span class="icon-beaker pop1 " alt="Popularity" title="Filter Firehose to entries rated red or better" onclick="firehose_set_options('color', 'red')"><span></span></span> 
		</span>
		</span>
		<span class="story-byline">
	
				
			Posted
				by 
		
		
			
				  msmash
			
		
		

		
		
		<time id="fhtime-93472087" datetime="on Tuesday September 05, 2017 @02:00AM">on Tuesday September 05, 2017 @02:00AM</time>
		
		
			 from the <span class="dept-text">security-woes</span> dept.
		
		</span>
	</div>
</header>

<div class="body" id="fhbody-93472087">
	
		
	

	
		
		<div id="text-93472087" class="p">
			
		 	
				An anonymous reader writes: <i>Android bootloader components from five major chipset vendors are affected by vulnerabilities that break the CoT (Chain of Trust) during the Android OS boot-up sequence, opening devices to attacks. The vulnerabilities were discovered with a new tool called BootStomp, developed by nine computer scientists from the University of California, Santa Barbara. <a href="https://www.bleepingcomputer.com/news/security/vulnerabilities-discovered-in-mobile-bootloaders-of-major-vendors/">Researchers analyzed five bootloaders from four vendors</a> (NVIDIA, Qualcomm, MediaTek, and Huawei/HiSilicon). Using BootStomp, researchers identified seven security flaws, six new and one previously known (CVE-2014-9798). Of the six new flaws, bootloader vendors already acknowledged five and are working on a fix. "Some of these vulnerabilities would allow an attacker to execute arbitrary code as part of the bootloader (thus compromising the entire chain of trust), or to perform permanent denial-of-service attacks," <a href="https://www.usenix.org/system/files/conference/usenixsecurity17/sec17-redini.pdf">the research team said</a> (PDF). "Our tool also identified two bootloader vulnerabilities that can be leveraged by an attacker with root privileges on the OS to unlock the device and break the CoT."</i><br>
		 	
		</div>

		

		

		
			
		
	</div>
	<aside class="grid_24 view_mode">
		
			<div class="units-12 story-detail-tags">
				<span id="sharethis-93472087" class="">
					
						

						

						
							<div class="story-controls">
								<div
								  class="janrainSocialPlaceholder"
								  data-janrain-url="https://mobile.slashdot.org/story/17/09/05/0257221/vulnerabilities-discovered-in-mobile-bootloaders-of-major-vendors"
								  data-janrain-title="Vulnerabilities Discovered In Mobile Bootloaders of Major Vendors"
								  data-janrain-message="Vulnerabilities Discovered In Mobile Bootloaders of Major Vendors @slashdot"
								></div>
							</div>
						
					
				</span>

				<div class="story-tags">
					<div class="tright tw">
						
							<span class="tright tags">
								
									<menu type="toolbar" class="edit-bar">
		<span id="tagbar-93472087" class="tag-bar none">
			<a  class="popular popular popular topic tag" rel="statictag" href="//slashdot.org/tag/" target="_blank"></a>

		</span>
		
			<a class="edit-toggle" href="/my/login/" onclick="show_login_box();return false;">
				<span class="icon-tag btn collapse"></span>
			</a>
		
		
		<div class="tag-menu">
			<input class="tag-entry default" type="text" value="apply tags">
		</div>
		

		
		

	</menu>
								
							</span>
						
					</div>
				</div>
			</div>

			
				
				
				
			 	
					<section class="grid_24" id="newa2footerv2">
						<div class="grid_6 pr">
							<h3><a title="Previous story" href="//tech.slashdot.org/story/17/09/04/2124221/oracle-staff-report-big-layoffs-across-solaris-sparc-teams?sdsrc=prev">&larr;</a></h3>
						</div>
						<div class="grid_12 rl">
							<h3>You may like to read:</h3>
						</div>
						<div class="grid_6 ns">
							<h3><a title="Next story" href="//tech.slashdot.org/story/17/09/05/1014235/android-one-is-anything-but-dead-google-reaffirms-with-xiaomi-mi-a1?sdsrc=next">&rarr;</a></h3>
						</div>
						<div class="grid_6">
							<span class="c">
								<a href="//tech.slashdot.org/story/17/09/04/2124221/oracle-staff-report-big-layoffs-across-solaris-sparc-teams?sdsrc=prev">Oracle Staff Report Big Layoffs Across Solaris, SPARC Teams </a>
							</span>
						</div>
						<div class="grid_12">
							<span class="c">
								
									
									
									
									

																				<h2><a href="//mobile.slashdot.org/story/17/07/10/2219215/would-you-buy-the-iphone-8-if-it-cost-1200?sdsrc=popbyskid">Would You Buy the iPhone 8 If It Cost $1,200?</a><br></h2>
																				<h2><a href="//mobile.slashdot.org/story/17/02/18/2013247/should-international-travelers-leave-their-phones-at-home?sdsrc=popbyskid">Should International Travelers Leave Their Phones At Home?</a><br></h2>
																				<h2><a href="//mobile.slashdot.org/story/17/06/19/0415243/a-colorado-group-wants-to-ban-smartphones-for-kids?sdsrc=popbyskid">A Colorado Group Wants To Ban Smartphones For Kids</a><br></h2>
																				<h2><a href="//mobile.slashdot.org/story/17/08/03/1953246/slashdot-asks-have-smartphones-destroyed-a-generation?sdsrc=popbyskid">Slashdot Asks: Have Smartphones Destroyed a Generation?</a><br></h2>
																				<h2><a href="//mobile.slashdot.org/story/16/09/09/2054207/apple-removed-headphone-jack-from-new-iphones-because-it-owns-largest-bluetooth-headphone-company?sdsrc=popbyskid">Apple Removed Headphone Jack From New iPhones Because It Owns Largest Bluetooth Headphone Company</a><br></h2>
									
								
								
									<h3 class="js_disp_only hide"><a class="jshandle_related" data-goto-url="//mobile.slashdot.org/submission/7388107/vulnerabilities-discovered-in-mobile-bootloaders-of-major-vendors?sdsrc=rel" href="#">Submission: Vulnerabilities Discovered in Mobile Bootloaders of Major Vendors</a></h3><script type="text/javascript">
		(function($){
			$('.js_disp_only').show();
			$('a.jshandle_related').on('click', '', function(e) {
				e.preventDefault();
				var url = $(this).data('goto-url');
				window.location = url
			});
		})($j);
	</script>
								
							</span>
						</div>
						<div class="grid_6">
							<span class="c">
								
									<a href="//tech.slashdot.org/story/17/09/05/1014235/android-one-is-anything-but-dead-google-reaffirms-with-xiaomi-mi-a1?sdsrc=next">Android One Is Anything But Dead, Google Reaffirms With Xiaomi Mi A1 </a>
								
							</span>
						</div>
					</section>
				
			
		
	</aside>
	



	</article>
			</div>
			</div>
		</div>
	</div>
	<!-- SMACKS: BEGIN RIGHT RAIL -->
	<aside id="slashboxes" class="rail-right">
		
                    <div id="slashboxesin" class="yui-b">
                            
                            
                            
                    </div>
		    <div class="railad adwrap-unviewed">
<div id='div-gpt-ad-300x250_a'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-300x250_a');});</script></div>
</div>
		    <div id="taboola-below-article-thumbnails"></div>
<script type="text/javascript">
	if ( isAdBlockActive) {
		window._taboola = window._taboola || [];
		_taboola.push({
			mode: 'thumbnails-rr2',
			container: 'taboola-below-article-thumbnails',
			placement: 'Below Article Thumbnails',
			target_type: 'mix'
		});
	};
</script>
		
	</aside>
		<!-- SMACKS: END RIGHT RAIL -->
</div>
<!-- END STORY CONTENT -->

<!-- THIS IS THE LOCATION FOR THE NEW STORY_B CODE -->
<div class="adwrap">
<div id='div-gpt-ad-728x90_b'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-728x90_b');});</script></div>
</div>
<div id="stackcommerce-adwrap" style="display:none;">
    <div style="margin:auto;max-width:970px;max-height:250px;">
        <div data-sc-widget data-publisher-id="66" data-categories="88,90" data-items-per-page="4" data-col-count="4" data-utm-source="slashdot.org" data-utm-content="story-deal-feed"></div>
    </div>
</div>
<script type="text/javascript">
	if ( isAdBlockActive) {
	    $.ajax({
            url: '/ajax.pl?op=nel',
            success: function(html){
                if(html){
                    $('#firehoselist article').eq(0).after(html);
                } else {
                    (function () {
                        var stackCommerceDiv = document.getElementById('stackcommerce-adwrap');
                        stackCommerceDiv.style = '';
                        var stackCommerce = document.createElement('script');
                        stackCommerce.async = true;
                        stackCommerce.type = 'text/javascript';
                        stackCommerce.src = 'https://widgets.stackcommerce.com/js-deal-feed/0.1/widget.js';
                        var node = document.getElementsByTagName('script')[0];
                        node.parentNode.insertBefore(stackCommerce, node);
                    })();
                }

            }
        });

	};
</script>
<!--------------------------->


<!-- SMACKS: BEGIN COMMENTS CONTAINER -->
<div class="container">
	<!-- SMACKS: BEGIN COMMENTS SECTION -->
	<div class="main-wrap">
		<div class="main-content">
			<div id="comments" class="a2commentwrap">
			<div>
					<a name="comments"></a>
<div id="comments" class="container">
	<div class="main-wrap">
		<div class="main-content">
			<section class="d2incommentspl">
				<div class="commentwrap" id="commentwrap">
					
						<div class="commentBox">
							<div class="title hide">
								<h4>
									
										<span class="escape-link"><a href="//mobile.slashdot.org/story/17/09/05/0257221/vulnerabilities-discovered-in-mobile-bootloaders-of-major-vendors" title="Back to Article - Vulnerabilities Discovered In Mobile Bootloaders of Major Vendors">Vulnerabilities Discovered In Mobile Bootloaders of Major Vendors</a></span>
									
									<span class="commentBoxLinks"><a href="#" onclick="D2.ajaxFetchComments(0,1); return false"><span id="more_comments_num_d"></span> More</a>



	| <span class="ind"></span><a href="//mobile.slashdot.org/comments.pl?sid=11073031&amp;op=reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=" onclick="D2.replyTo(0); return false;">Reply</a>


	<a class="login"  href="//mobile.slashdot.org/login.pl" onclick="show_login_box(); return false">Login</a></span>
								</h4>
							</div>
						</div>
					

					<section class="grid_24" id="d2header"><div>
						
							<h2 class="commentspl test"><a title="Back to Article - Vulnerabilities Discovered In Mobile Bootloaders of Major Vendors" href="//mobile.slashdot.org/story/17/09/05/0257221/vulnerabilities-discovered-in-mobile-bootloaders-of-major-vendors">Vulnerabilities Discovered In Mobile Bootloaders of Major Vendors</a></h2>
						
						<nav class="grid_24">
							<div class="grid_14 widthauto">
							
								<span class="ind"></span><a class="btn first" href="//mobile.slashdot.org/comments.pl?sid=11073031&amp;op=reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=" onclick="D2.replyTo(0); return false;">Post</a>
							
							<!-- <a href="//mobile.slashdot.org/search.pl?op=comments&amp;sid=11073031" class="btn">Search <span class="totalcommentcnt">61</span> Comments</a> -->
							
								
									<a href="#" onclick="D2.ajaxFetchComments(0,1,'','',-1); return false" class="btn" id="d2loadall">Load All Comments</a>
								
							
							
								</div>
								<div class="grid_10 d1or2">
							

							
								<div id="d2out" class="horizontal rooted grid_15">
									<div id="d2act" class="hide">
										<div class="loki" id="gods">
											<script type="text/javascript">
												 $(function(){
													 D2.slider = new D2.Slider(
														 D2.user_threshold(),
														 D2.user_highlightthresh(),
														 'x'
													 );
												 });
											</script>
											<div id="bones" class="grid_12">
												<div class="ccw-count-container grid_24">
													<span id="ccw-full-count-text" class="grid_8 ccw-count-text tcenter"><span></span><span id="ccw-full-phrase">&nbsp;Full</span></span>
													<span id="ccw-abbr-count-text" class="grid_8 ccw-count-text"><span></span><span id="ccw-abbr-phrase">&nbsp;Abbreviated</span></span>
													<span id="ccw-hide-count-text" class="grid_8 ccw-count-text tleft"><span></span><span id="ccw-hide-phrase">&nbsp;Hidden</span></span>
												</div>
												<div id="ccw">
													<div id="ccw-body" class="ccw-core">
														<div id="ccw-panel-container" class="ccw-core">
															<div id="ccw-full-panel" class="ccw-panel">
																/Sea<div class="ccw-panel-border"></div>
																<div id="ccw-full-count-pos" class="ccw-core-pos ccw-count-pos"></div>
															</div>
															<div id="ccw-abbr-panel" class="ccw-panel">
																<div class="ccw-panel-border"></div>
																<div id="ccw-abbr-count-pos" class="ccw-core-pos ccw-count-pos"></div>
															</div>
															<div id="ccw-hide-panel" class="ccw-panel">
																<div id="ccw-hide-count-pos" class="ccw-core-pos ccw-count-pos"></div>
															</div>
														</div>
														<div id="ccw-control" class="ccw-core">
															<div id="ccw-centering-rail" class="ccw-core">
																<div id="ccw-hide-bar-pos" class="ccw-core-pos">
																	<div id="ccw-hide-bar" class="ccw-bar">
																		<div id="ccw-hide-bar-tab" class="ccw-bar-tab"></div>
																		<div class="ccwa"></div>
																		<div class="ccwb"></div>
																		<div id="ccw-hide-bar-upzone" class="ccw-upzone" onclick="D2.slider.stepTHT(HIDE_BAR, +1)"></div>
																		<div id="ccw-hide-bar-downzone" class="ccw-downzone" onclick="D2.slider.stepTHT(HIDE_BAR, -1)"></div>
																	</div>
																</div>
																<div id="ccw-abbr-bar-pos" class="ccw-core-pos">
																	<div id="ccw-abbr-bar" class="ccw-bar">
																		<div id="ccw-abbr-bar-tab" class="ccw-bar-tab"></div>
																		<div class="ccwa"></div>
																		<div class="ccwb"></div>
																		<div id="ccw-abbr-bar-upzone" class="ccw-upzone" onclick="D2.slider.stepTHT(ABBR_BAR, +1)"></div>
																		<div id="ccw-abbr-bar-downzone" class="ccw-downzone" onclick="D2.slider.stepTHT(ABBR_BAR, -1)"></div>
																	</div>
																</div>
															</div>
														</div>
													</div>
													<div class="ccw-score-label grid_24">
														<div class="grid_3"><span class="sc">Score:</span></div>
														<div class="grid_3">5<span class="lg"></span></div>
														<div class="grid_3">4<span class="lg"></span></div>
														<div class="grid_3">3<span class="lg"></span></div>
														<div class="grid_3">2<span class="lg"></span></div>
														<div class="grid_3">1<span class="lg"></span></div>
														<div class="grid_3">0<span class="lg"></span></div>
														<div class="grid_3">-1<span class="lg"></span></div>
													</div>
												</div>
											</div>
											<div class="commentControlFooter">
												<a href="#" onclick="D2.ajaxFetchComments(0,1); return false"><span id="more_comments_num_c"></span> More</a>



	| <span class="ind"></span><a href="//mobile.slashdot.org/comments.pl?sid=11073031&amp;op=reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=" onclick="D2.replyTo(0); return false;">Reply</a>


	<a class="login"  href="//mobile.slashdot.org/login.pl" onclick="show_login_box(); return false">Login</a><div id="login_cover" class="hide" onclick="hide_login_box()"></div>
<div id="login_box" class="hide">
	<div id="login_box_content">
		<div id='embbeded_login_modal' class="hide">
<form action="https://slashdot.org/my/login" method="post" onsubmit="if (global_returnto) { this.returnto.value = global_returnto }" class="embedded"><fieldset style="-webkit-border-radius:10px 10px 0 0;border-radius:10px 10px 0 0;-moz-border-radius:10px 10px 0 0">
<div style='height:25px;'>&nbsp;</div>
    <input type="hidden" name="returnto" value="//mobile.slashdot.org/comments.pl?sid=11073031">
    <input type="hidden" name="op" value="userlogin">
    <p>
        <label class="fleft" for="unickname">Nickname:</label>
        <input type="text" name="unickname" value="">
    </p>
    <p>
        <label class="fleft" for="upasswd">Password:</label>
        <input type="password" name="upasswd" placeholder="6-20 characters long">
    </p>
    <label class="checkbox"><input type="checkbox" name="login_temp" value="yes"> Public Terminal</label>
    <br>
    <hr>
    <input type="submit" name="userlogin" value="Log In" class="fno"> <a href="//slashdot.org/my/mailpassword" class="btn link" onclick="getModalPrefs('sendPasswdModal', 'Retrieve Password', 1); return false;">Forgot your password?</a>
</fieldset></form>

<div id="janrainEngageEmbed"></div>
<div class="actions">
 <a class="ico close" onclick="hide_login_slider();" href=""><span>Close</span></a>
</div>
</div>
		<div class="actions">
			<a class="ico close" href="#" onclick="hide_login_box(); return false"><span>Close</span></a>
		</div>
	</div>
</div>
<script type="text/javascript">logged_in = 0</script>
											</div>
											<div id="commentControlBoxStatus" class="hide"></div>
										</div>
									</div>
								</div>
							
							
							<a href="//mobile.slashdot.org/search.pl?op=comments&amp;sid=11073031" class="ui-icon search_comments">Search <span class="totalcommentcnt">61</span> Comments</a>
							
								<a class="pref ui-icon-w" href="//mobile.slashdot.org/users.pl" onclick="show_login_box(); $('#modal_box').addClass('login'); return false;">Log In/Create an Account</a>
							
						</div>
					</nav>
					<section id="besttabs" class="grid_24">
						<span class="legend">Comments Filter:</span>
						<ul class="besttabslist">
							<li class="active">
								<a href="#" data-filter-url="//mobile.slashdot.org/story/17/09/05/0257221/vulnerabilities-discovered-in-mobile-bootloaders-of-major-vendors#comments">All</a>
							</li>
						
							<li >
								<a href="" data-filter-url="//mobile.slashdot.org/story/17/09/05/0257221/vulnerabilities-discovered-in-mobile-bootloaders-of-major-vendors/insightful-comments#comments">Insightful</a>
							</li>
						
							<li >
								<a href="" data-filter-url="//mobile.slashdot.org/story/17/09/05/0257221/vulnerabilities-discovered-in-mobile-bootloaders-of-major-vendors/informative-comments#comments">Informative</a>
							</li>
						
							<li >
								<a href="" data-filter-url="//mobile.slashdot.org/story/17/09/05/0257221/vulnerabilities-discovered-in-mobile-bootloaders-of-major-vendors/interesting-comments#comments">Interesting</a>
							</li>
						
							<li >
								<a href="" data-filter-url="//mobile.slashdot.org/story/17/09/05/0257221/vulnerabilities-discovered-in-mobile-bootloaders-of-major-vendors/funny-comments#comments">Funny</a>
							</li>
						
					</ul>
					<script>
					(function($){
						$('#besttabs').show();
						$('.besttabslist').on('click', 'li a', function(e){
							e.preventDefault();
							var url = $(this).data('filter-url');
							//console.log('URL= ', url);
							$(this)
								.closest('ul').find('li').removeClass('active')
								.end()
								.closest('li').addClass('active');
							window.location = url;
						});
					})($j);
					</script>
			</section>
				<aside class="grid_24">
					<p>
						<small><strong>The Fine Print:</strong> The following comments are owned by whoever posted them.  We are not responsible for them in any way.</small>
					</p>
				</aside>
			</section>
			
		</div>
	</div>
</div><script src="//a.fsdn.com/sd/comments-minified.js?1f8cff0f988a8983" type="text/javascript"></script>


<script type="text/javascript">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</script>




	
	
	
	
		<ul id="commentlisting" class="d2">
			<li id="tree_55139661" class="comment full contain"><span class="ind"></span>
<div id="comment_status_55139661" class="commentstatus"></div>
<div id="comment_55139661" class="cw">
	<div id="comment_top_55139661" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55139661" name="comment_link_55139661" href="//mobile.slashdot.org/comments.pl?sid=11073031&amp;cid=55139661" onclick="return D2.setFocusComment(55139661)" >Free the Bootloaders</a>


		 	<span id="comment_score_55139661" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55139661); return false"><span class=opt>Score:</span>5</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~ShakaUVM">ShakaUVM</a>  <span class="uid"><a href="//slashdot.org/~ShakaUVM">( 157947 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55139661">		
		on Tuesday September 05, 2017 @02:25AM (<span class="ind"></span><a href="//mobile.slashdot.org/comments.pl?sid=11073031&amp;cid=55139661">#55139661</a>)
		<small><a href="http://www.customtf.net/" title="http://www.customtf.net/" class="user_homepage_display">Homepage</a>
<a href="//slashdot.org/~ShakaUVM/journal/" title="Friday April 25, 2008 @11:31PM" class="user_journal_display">Journal</a> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55139661"><p>Am I the only one that thinks that this information should have been released to the people making rootkits, and not the vendors?</p><p>Time has shown that the vendors cannot be trusted and are far more evil than the people allowing people root access on their own machines. Bloatware, regressions through updates (often forced or nagged into acceptance), pushing their own branded crapware, removing options from the user, *preventing* the user from making the machine work the way they want it to, and so forth. You want to *not* have the screen turn on automatically when it starts charging? Sorry, you don't have permissions to do that on your own machine. They're evil. They should get the second look at these vulnerabilities after everyone who wants to root their devices has done so.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55139661">
<span class="ind"></span><a id="reply_link_55139661" class="btn link" href="//mobile.slashdot.org/comments.pl?sid=11073031&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=55139661" onclick="D2.replyTo(55139661); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Free the Bootloaders by ShakaUVM @slashdot" data-url="https://mobile.slashdot.org/comments.pl?sid=11073031&cid=55139661" data-title="Free the Bootloaders">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Free the Bootloaders by ShakaUVM" data-url="https://mobile.slashdot.org/comments.pl?sid=11073031&cid=55139661" data-title="Free the Bootloaders">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Free the Bootloaders by ShakaUVM" data-url="https://mobile.slashdot.org/comments.pl?sid=11073031&cid=55139661" data-title="Free the Bootloaders">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://mobile.slashdot.org/comments.pl?sid=11073031%26cid=55139661" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_55139661" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//mobile.slashdot.org/comments.pl?sid=11073031&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=55139661" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_55139661"></div>

<ul id="group_55139661">
	<li id="hiddens_55139661" class="hide"></li>
</ul>

<ul id="commtree_55139661"><li id="tree_55139725" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55139725" class="commentstatus"></div>
<div id="comment_55139725" class="cw">
</div>

<div id="replyto_55139725"></div>

<ul id="group_55139725">
	<li id="hiddens_55139725" class="hide"></li>
</ul>

</li><li id="tree_55139729" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55139729" class="commentstatus"></div>
<div id="comment_55139729" class="cw">
</div>

<div id="replyto_55139729"></div>

<ul id="group_55139729">
	<li id="hiddens_55139729" class="hide"></li>
</ul>

<ul id="commtree_55139729"><li id="tree_55139889" class="comment full contain"><span class="ind"></span>
<div id="comment_status_55139889" class="commentstatus"></div>
<div id="comment_55139889" class="cw">
	<div id="comment_top_55139889" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55139889" name="comment_link_55139889" href="//mobile.slashdot.org/comments.pl?sid=11073031&amp;cid=55139889" onclick="return D2.setFocusComment(55139889)" >Re:Free the Bootloaders</a>


		 	<span id="comment_score_55139889" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55139889); return false"><span class=opt>Score:</span>5</a>, Interesting)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Opportunist">Opportunist</a>  <span class="uid"><a href="//slashdot.org/~Opportunist">( 166417 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55139889">		
		on Tuesday September 05, 2017 @04:59AM (<span class="ind"></span><a href="//mobile.slashdot.org/comments.pl?sid=11073031&amp;cid=55139889">#55139889</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55139889"><p>The sad realization is that the "black market" has in general lower and less harmful impact on your security and privacy than the device maker.</p><p>Or, in a more direct way, the chance that a jailbreak tool gives you your privacy back is higher than a rootkit stealing even more of it. What could be stolen that has already been stolen?</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55139889">
<span class="ind"></span><a id="reply_link_55139889" class="btn link" href="//mobile.slashdot.org/comments.pl?sid=11073031&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=55139889" onclick="D2.replyTo(55139889); return false;">Reply to This</a> <span class="ind"></span><a class="btn link" href="//mobile.slashdot.org/comments.pl?sid=11073031&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;cid=55139729" onclick="return D2.selectParent(55139729)">Parent</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Re:Free the Bootloaders by Opportunist @slashdot" data-url="https://mobile.slashdot.org/comments.pl?sid=11073031&cid=55139889" data-title="Re:Free the Bootloaders">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Re:Free the Bootloaders by Opportunist" data-url="https://mobile.slashdot.org/comments.pl?sid=11073031&cid=55139889" data-title="Re:Free the Bootloaders">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Re:Free the Bootloaders by Opportunist" data-url="https://mobile.slashdot.org/comments.pl?sid=11073031&cid=55139889" data-title="Re:Free the Bootloaders">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://mobile.slashdot.org/comments.pl?sid=11073031%26cid=55139889" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_55139889" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//mobile.slashdot.org/comments.pl?sid=11073031&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=55139889" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_55139889"></div>

<ul id="group_55139889">
	<li id="hiddens_55139889" class="hide"></li>
</ul>

<ul id="commtree_55139889"><li id="tree_55140033" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55140033" class="commentstatus"></div>
<div id="comment_55140033" class="cw">
</div>

<div id="replyto_55140033"></div>

<ul id="group_55140033">
	<li id="hiddens_55140033" class="hide"></li>
</ul>

<ul id="commtree_55140033"><li id="tree_55140223" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55140223" class="commentstatus"></div>
<div id="comment_55140223" class="cw">
	<div id="comment_top_55140223" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55140223" name="comment_link_55140223" href="//mobile.slashdot.org/comments.pl?sid=11073031&amp;cid=55140223" onclick="return D2.setFocusComment(55140223)" >Re:</a>


		 	<span id="comment_score_55140223" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55140223); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Opportunist">Opportunist</a>  <span class="uid"><a href="//slashdot.org/~Opportunist">( 166417 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55140223"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55140223"><p>And it's legal to do so.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55140223">

</div>
</div>

<div id="replyto_55140223"></div>

<ul id="group_55140223">
	<li id="hiddens_55140223" class="hide"></li>
</ul>

</li></ul></li><li id="tree_55140309" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55140309" class="commentstatus"></div>
<div id="comment_55140309" class="cw">
	<div id="comment_top_55140309" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55140309" name="comment_link_55140309" href="//mobile.slashdot.org/comments.pl?sid=11073031&amp;cid=55140309" onclick="return D2.setFocusComment(55140309)" >Re:</a>


		 	<span id="comment_score_55140309" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55140309); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span>Anonymous Coward</span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55140309"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55140309"><blockquote><div><p>What could be stolen that has already been stolen?</p></div></blockquote><p>Assuming that it does what is advertised, i.e. allows root or flashing of an unsigned custom rom, nothing. It gives back control of the device to the device's owner.</p><blockquote><div><p>The sad realization is that the "black market" has in general lower and less harmful impact on your security and privacy than the device maker.</p></div></blockquote><p>It's an even sadder realization that the person who bought the device is NOT considered to be trusted <i>by default</i>, and that said person must hack the devic<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_55140309">

</div>
</div>

<div id="replyto_55140309"></div>

<ul id="group_55140309">
	<li id="hiddens_55140309" class="hide"></li>
</ul>

<ul id="commtree_55140309"><li id="tree_55140683" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55140683" class="commentstatus"></div>
<div id="comment_55140683" class="cw">
	<div id="comment_top_55140683" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55140683" name="comment_link_55140683" href="//mobile.slashdot.org/comments.pl?sid=11073031&amp;cid=55140683" onclick="return D2.setFocusComment(55140683)" >Re:</a>


		 	<span id="comment_score_55140683" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55140683); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Opportunist">Opportunist</a>  <span class="uid"><a href="//slashdot.org/~Opportunist">( 166417 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55140683"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55140683"><p>The ultimate sad realization is that the person who bought the device isn't the one who gets to decide who to trust. I trust myself by default. But I am not the one who gets to trust. The manufacturer of the device I pay for gets to say who the device that (again) I PAID FOR trusts.</p><p>THAT is what's ultimately wrong here. The fundamental aspect of ownership is to have total control over something. I own my living room table. I can, if I so please, turn it into firewood. Or sell it. I may put a different coat o<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_55140683">

</div>
</div>

<div id="replyto_55140683"></div>

<ul id="group_55140683">
	<li id="hiddens_55140683" class="hide"></li>
</ul>

</li><li id="tree_55140941" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55140941" class="commentstatus"></div>
<div id="comment_55140941" class="cw">
	<div id="comment_top_55140941" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55140941" name="comment_link_55140941" href="//mobile.slashdot.org/comments.pl?sid=11073031&amp;cid=55140941" onclick="return D2.setFocusComment(55140941)" >Re:</a>


		 	<span id="comment_score_55140941" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55140941); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Sloppy">Sloppy</a>  <span class="uid"><a href="//slashdot.org/~Sloppy">( 14984 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55140941"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55140941"><blockquote><div><p>It's an even sadder realization that the person who bought the device is NOT considered to be trusted by default, and that said person must hack the device they own to get that trust back.</p></div></blockquote><p> <em>Never</em> buy any hardware until after you have at least asked who is its master. Whose interests does that computer serve?</p><p>And if the master isn't you, then instead of asking how much you pay for it, ask how much you're being paid to use it.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55140941">

</div>
</div>

<div id="replyto_55140941"></div>

<ul id="group_55140941">
	<li id="hiddens_55140941" class="hide"></li>
</ul>

<ul id="commtree_55140941"><li id="tree_55141031" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55141031" class="commentstatus"></div>
<div id="comment_55141031" class="cw">
	<div id="comment_top_55141031" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55141031" name="comment_link_55141031" href="//mobile.slashdot.org/comments.pl?sid=11073031&amp;cid=55141031" onclick="return D2.setFocusComment(55141031)" >Re:</a>


		 	<span id="comment_score_55141031" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55141031); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~aitikin">aitikin</a>  <span class="uid"><a href="//slashdot.org/~aitikin">( 909209 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55141031"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55141031">So...curious...what hardware do you use?</div>
	</div>

	<div class="commentSub" id="comment_sub_55141031">

</div>
</div>

<div id="replyto_55141031"></div>

<ul id="group_55141031">
	<li id="hiddens_55141031" class="hide"></li>
</ul>

</li></ul></li></ul></li><li id="hidestring_55139889"><noscript><b class='more'><span class="ind"></span><a href="//mobile.slashdot.org/comments.pl?sid=11073031&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55139889">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_55139921" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55139921" class="commentstatus"></div>
<div id="comment_55139921" class="cw">
</div>

<div id="replyto_55139921"></div>

<ul id="group_55139921">
	<li id="hiddens_55139921" class="hide"></li>
</ul>

</li><li id="hidestring_55139729"><noscript><b class='more'><span class="ind"></span><a href="//mobile.slashdot.org/comments.pl?sid=11073031&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55139729">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_55139829" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55139829" class="commentstatus"></div>
<div id="comment_55139829" class="cw">
</div>

<div id="replyto_55139829"></div>

<ul id="group_55139829">
	<li id="hiddens_55139829" class="hide"></li>
</ul>

</li><li id="tree_55139887" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55139887" class="commentstatus"></div>
<div id="comment_55139887" class="cw">
	<div id="comment_top_55139887" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55139887" name="comment_link_55139887" href="//mobile.slashdot.org/comments.pl?sid=11073031&amp;cid=55139887" onclick="return D2.setFocusComment(55139887)" >Re:</a>


		 	<span id="comment_score_55139887" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55139887); return false"><span class=opt>Score:</span>2</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span>Anonymous Coward</span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55139887"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55139887"><p>&gt; Time has shown that the vendors cannot be trusted and are far more evil than the people allowing people root access on their own machines.</p><p>Yah, but people will stop buying the bad ones, thus bankrupting those evil vendors. The Invisible Hand and Ponies will surely fix that!</p><p>Oh, wait...</p><p>Yes, all a bit tongue-in-cheek, but I think we're seeing a failure of the maxim "market forces for the benefit of all" dogma here.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55139887">

</div>
</div>

<div id="replyto_55139887"></div>

<ul id="group_55139887">
	<li id="hiddens_55139887" class="hide"></li>
</ul>

<ul id="commtree_55139887"><li id="tree_55140559" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55140559" class="commentstatus"></div>
<div id="comment_55140559" class="cw">
	<div id="comment_top_55140559" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55140559" name="comment_link_55140559" href="//mobile.slashdot.org/comments.pl?sid=11073031&amp;cid=55140559" onclick="return D2.setFocusComment(55140559)" >Re:</a>


		 	<span id="comment_score_55140559" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55140559); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~alexgieg">alexgieg</a>  <span class="uid"><a href="//slashdot.org/~alexgieg">( 948359 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55140559"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55140559"><p><div class="quote"><p>I think we're seeing a failure of the maxim "market forces for the benefit of all" dogma here.</p></div><p>Maybe, but it's difficult to say for sure when the whole thing is wrapped under State-sanctioned anti-free-market monopoly-inducing violence-enforced system of intellectual "property" laws: copyrights, patents and trademarks. Plus the selling of monopolies over radio-frequency bands, tons of incumbent-protecting regulatory laws in all markets, Customs-protection of systemic internal inefficiencies, legal impediments for individuals to use for their own benefit the same tactics corporations use etc. etc. etc<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_55140559">

</div>
</div>

<div id="replyto_55140559"></div>

<ul id="group_55140559">
	<li id="hiddens_55140559" class="hide"></li>
</ul>

</li></ul></li><li id="tree_55139913" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55139913" class="commentstatus"></div>
<div id="comment_55139913" class="cw">
	<div id="comment_top_55139913" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55139913" name="comment_link_55139913" href="//mobile.slashdot.org/comments.pl?sid=11073031&amp;cid=55139913" onclick="return D2.setFocusComment(55139913)" >Re:</a>


		 	<span id="comment_score_55139913" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55139913); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~admin7087">Unknown User</a>  <span class="uid"><a href="//slashdot.org/~admin7087">( 4795349 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55139913"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55139913">No, you're not the only one. This so-called "chain of trust" is ridiculous. People are <i>forced to trust</i> binary blobs of various nebulous business entities with a long history of nefarious business practices, bad security, and unnecessary collusion with sometimes shady government entities. That's pretty much the opposite of trustworthiness.</div>
	</div>

	<div class="commentSub" id="comment_sub_55139913">

</div>
</div>

<div id="replyto_55139913"></div>

<ul id="group_55139913">
	<li id="hiddens_55139913" class="hide"></li>
</ul>

</li><li id="tree_55140529" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55140529" class="commentstatus"></div>
<div id="comment_55140529" class="cw">
</div>

<div id="replyto_55140529"></div>

<ul id="group_55140529">
	<li id="hiddens_55140529" class="hide"></li>
</ul>

</li><li id="tree_55140551" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55140551" class="commentstatus"></div>
<div id="comment_55140551" class="cw">
</div>

<div id="replyto_55140551"></div>

<ul id="group_55140551">
	<li id="hiddens_55140551" class="hide"></li>
</ul>

</li><li id="hidestring_55139661"><noscript><b class='more'><span class="ind"></span><a href="//mobile.slashdot.org/comments.pl?sid=11073031&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55139661">5 replies</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_55139665" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55139665" class="commentstatus"></div>
<div id="comment_55139665" class="cw">
</div>

<div id="replyto_55139665"></div>

<ul id="group_55139665">
	<li id="hiddens_55139665" class="hide"></li>
</ul>

<ul id="commtree_55139665"><li id="tree_55139695" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55139695" class="commentstatus"></div>
<div id="comment_55139695" class="cw">
	<div id="comment_top_55139695" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55139695" name="comment_link_55139695" href="//mobile.slashdot.org/comments.pl?sid=11073031&amp;cid=55139695" onclick="return D2.setFocusComment(55139695)" >Re: iOS really is more secure.</a>


		 	<span id="comment_score_55139695" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55139695); return false"><span class=opt>Score:</span>1</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span>Anonymous Coward</span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55139695"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55139695"><p>Hey, remember that Ma c virus tbat remained undetected for 2 years?</p><p>Nobody reports anything to APL anymore because why would they?</p><p>Time and again, it's blacklisted researchers demonstrating their apps... Plus they can make more money selling too the black market (sadly).</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55139695">

</div>
</div>

<div id="replyto_55139695"></div>

<ul id="group_55139695">
	<li id="hiddens_55139695" class="hide"></li>
</ul>

<ul id="commtree_55139695"><li id="tree_55140155" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55140155" class="commentstatus"></div>
<div id="comment_55140155" class="cw">
	<div id="comment_top_55140155" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55140155" name="comment_link_55140155" href="//mobile.slashdot.org/comments.pl?sid=11073031&amp;cid=55140155" onclick="return D2.setFocusComment(55140155)" >Re:  iOS really is more secure.</a>


		 	<span id="comment_score_55140155" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55140155); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~that+this+is+not+und">that this is not und</a>  <span class="uid"><a href="//slashdot.org/~that+this+is+not+und">( 1026860 )</a></span></a> <a href="/faq/subscriptions.shtml#subscription_other_advantages">*</a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55140155"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55140155"><p>iOS is a richer niche of users (as we are constantly reminded) for criminals and tla agents to tap into. Obviously iOS exploits are more valuable and will be exploited at a higher level &amp; to a higher degree than exploits for the gear the proles use.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55140155">

</div>
</div>

<div id="replyto_55140155"></div>

<ul id="group_55140155">
	<li id="hiddens_55140155" class="hide"></li>
</ul>

</li></ul></li><li id="tree_55140013" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55140013" class="commentstatus"></div>
<div id="comment_55140013" class="cw">
</div>

<div id="replyto_55140013"></div>

<ul id="group_55140013">
	<li id="hiddens_55140013" class="hide"></li>
</ul>

<ul id="commtree_55140013"><li id="tree_55140557" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55140557" class="commentstatus"></div>
<div id="comment_55140557" class="cw">
</div>

<div id="replyto_55140557"></div>

<ul id="group_55140557">
	<li id="hiddens_55140557" class="hide"></li>
</ul>

</li><li id="tree_55140789" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55140789" class="commentstatus"></div>
<div id="comment_55140789" class="cw">
	<div id="comment_top_55140789" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55140789" name="comment_link_55140789" href="//mobile.slashdot.org/comments.pl?sid=11073031&amp;cid=55140789" onclick="return D2.setFocusComment(55140789)" >Re:</a>


		 	<span id="comment_score_55140789" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55140789); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~ArchieBunker">ArchieBunker</a>  <span class="uid"><a href="//slashdot.org/~ArchieBunker">( 132337 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55140789"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55140789"><p>I think a jailbroken iPhone is the best of both worlds. Apple has the best hardware but locks it down unreasonably. My aging iPhone 5C (circa 2013) was still getting OS updates until iOS 11 was released. Show me an Android phone getting updates four years later.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55140789">

</div>
</div>

<div id="replyto_55140789"></div>

<ul id="group_55140789">
	<li id="hiddens_55140789" class="hide"></li>
</ul>

</li><li id="hidestring_55140013"><noscript><b class='more'><span class="ind"></span><a href="//mobile.slashdot.org/comments.pl?sid=11073031&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55140013">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="hidestring_55139665"><noscript><b class='more'><span class="ind"></span><a href="//mobile.slashdot.org/comments.pl?sid=11073031&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55139665">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_55139667" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55139667" class="commentstatus"></div>
<div id="comment_55139667" class="cw">
</div>

<div id="replyto_55139667"></div>

<ul id="group_55139667">
	<li id="hiddens_55139667" class="hide"></li>
</ul>

</li><li id="tree_55139709" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55139709" class="commentstatus"></div>
<div id="comment_55139709" class="cw">
	<div id="comment_top_55139709" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55139709" name="comment_link_55139709" href="//mobile.slashdot.org/comments.pl?sid=11073031&amp;cid=55139709" onclick="return D2.setFocusComment(55139709)" >For the next few weeks....</a>


		 	<span id="comment_score_55139709" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55139709); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~BeCre8iv">BeCre8iv</a>  <span class="uid"><a href="//slashdot.org/~BeCre8iv">( 563502 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55139709"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55139709">We get to root our phones.</div>
	</div>

	<div class="commentSub" id="comment_sub_55139709">

</div>
</div>

<div id="replyto_55139709"></div>

<ul id="group_55139709">
	<li id="hiddens_55139709" class="hide"></li>
</ul>

<ul id="commtree_55139709"><li id="tree_55140051" class="comment full contain"><span class="ind"></span>
<div id="comment_status_55140051" class="commentstatus"></div>
<div id="comment_55140051" class="cw">
	<div id="comment_top_55140051" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55140051" name="comment_link_55140051" href="//mobile.slashdot.org/comments.pl?sid=11073031&amp;cid=55140051" onclick="return D2.setFocusComment(55140051)" >Re:For the next few weeks....</a>


		 	<span id="comment_score_55140051" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55140051); return false"><span class=opt>Score:</span>5</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~drinkypoo">drinkypoo</a>  <span class="uid"><a href="//slashdot.org/~drinkypoo">( 153816 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55140051">		 &lt;<a href="mailto:martin.espinoza%40gmail.com">martin.espinoza@gmail.com</a>&gt;
		on Tuesday September 05, 2017 @06:44AM (<span class="ind"></span><a href="//mobile.slashdot.org/comments.pl?sid=11073031&amp;cid=55140051">#55140051</a>)
		<small><a href="http://hyperlogos.org/" title="http://hyperlogos.org/" class="user_homepage_display">Homepage</a>
<a href="//slashdot.org/~drinkypoo/journal/" title="Sunday September 03, 2017 @08:58AM" class="user_journal_display">Journal</a> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55140051"><p>Most devices won't receive any updates even if they are totally compromised, because that's how much of a shit the vendors give about their customers. Only devices getting updates anyway will get locked back down.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55140051">
<span class="ind"></span><a id="reply_link_55140051" class="btn link" href="//mobile.slashdot.org/comments.pl?sid=11073031&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=55140051" onclick="D2.replyTo(55140051); return false;">Reply to This</a> <span class="ind"></span><a class="btn link" href="//mobile.slashdot.org/comments.pl?sid=11073031&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;cid=55139709" onclick="return D2.selectParent(55139709)">Parent</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Re:For the next few weeks.... by drinkypoo @slashdot" data-url="https://mobile.slashdot.org/comments.pl?sid=11073031&cid=55140051" data-title="Re:For the next few weeks....">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Re:For the next few weeks.... by drinkypoo" data-url="https://mobile.slashdot.org/comments.pl?sid=11073031&cid=55140051" data-title="Re:For the next few weeks....">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Re:For the next few weeks.... by drinkypoo" data-url="https://mobile.slashdot.org/comments.pl?sid=11073031&cid=55140051" data-title="Re:For the next few weeks....">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://mobile.slashdot.org/comments.pl?sid=11073031%26cid=55140051" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_55140051" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//mobile.slashdot.org/comments.pl?sid=11073031&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=55140051" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_55140051"></div>

<ul id="group_55140051">
	<li id="hiddens_55140051" class="hide"></li>
</ul>

<ul id="commtree_55140051"><li id="tree_55140339" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55140339" class="commentstatus"></div>
<div id="comment_55140339" class="cw">
	<div id="comment_top_55140339" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55140339" name="comment_link_55140339" href="//mobile.slashdot.org/comments.pl?sid=11073031&amp;cid=55140339" onclick="return D2.setFocusComment(55140339)" >Re:</a>


		 	<span id="comment_score_55140339" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55140339); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Voyager529">Voyager529</a>  <span class="uid"><a href="//slashdot.org/~Voyager529">( 1363959 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55140339"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55140339"><p><div class="quote"><p>Most devices won't receive any updates even if they are totally compromised, because that's how much of a shit the vendors give about their customers. Only devices getting updates anyway will get locked back down.</p></div><p>Ordinarily, yes. But these vulnerabilities have the potential of removing the vendor's ability to retain control over the devices and allowing users to obtain root access on phones that previously did not have that capability..so I have a gut feeling the vendors will be coming out of the woodwork on this.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55140339">

</div>
</div>

<div id="replyto_55140339"></div>

<ul id="group_55140339">
	<li id="hiddens_55140339" class="hide"></li>
</ul>

</li></ul></li></ul></li><li id="tree_55139715" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55139715" class="commentstatus"></div>
<div id="comment_55139715" class="cw">
</div>

<div id="replyto_55139715"></div>

<ul id="group_55139715">
	<li id="hiddens_55139715" class="hide"></li>
</ul>

<ul id="commtree_55139715"><li id="tree_55139719" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55139719" class="commentstatus"></div>
<div id="comment_55139719" class="cw">
</div>

<div id="replyto_55139719"></div>

<ul id="group_55139719">
	<li id="hiddens_55139719" class="hide"></li>
</ul>

<ul id="commtree_55139719"><li id="tree_55139891" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55139891" class="commentstatus"></div>
<div id="comment_55139891" class="cw">
	<div id="comment_top_55139891" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55139891" name="comment_link_55139891" href="//mobile.slashdot.org/comments.pl?sid=11073031&amp;cid=55139891" onclick="return D2.setFocusComment(55139891)" >Re:</a>


		 	<span id="comment_score_55139891" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55139891); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Opportunist">Opportunist</a>  <span class="uid"><a href="//slashdot.org/~Opportunist">( 166417 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55139891"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55139891"><p>Oh c'mon, it was hardly worse than the ladyboy we have now.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55139891">

</div>
</div>

<div id="replyto_55139891"></div>

<ul id="group_55139891">
	<li id="hiddens_55139891" class="hide"></li>
</ul>

</li><li id="tree_55140161" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55140161" class="commentstatus"></div>
<div id="comment_55140161" class="cw">
	<div id="comment_top_55140161" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55140161" name="comment_link_55140161" href="//mobile.slashdot.org/comments.pl?sid=11073031&amp;cid=55140161" onclick="return D2.setFocusComment(55140161)" >Re: Well...</a>


		 	<span id="comment_score_55140161" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55140161); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~that+this+is+not+und">that this is not und</a>  <span class="uid"><a href="//slashdot.org/~that+this+is+not+und">( 1026860 )</a></span></a> <a href="/faq/subscriptions.shtml#subscription_other_advantages">*</a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55140161"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55140161"><p>Was there a divorce and wedding I missed hearing about? Reggie changed his name to Michael?</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55140161">

</div>
</div>

<div id="replyto_55140161"></div>

<ul id="group_55140161">
	<li id="hiddens_55140161" class="hide"></li>
</ul>

</li></ul></li><li id="tree_55139999" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55139999" class="commentstatus"></div>
<div id="comment_55139999" class="cw">
</div>

<div id="replyto_55139999"></div>

<ul id="group_55139999">
	<li id="hiddens_55139999" class="hide"></li>
</ul>

</li><li id="hidestring_55139715"><noscript><b class='more'><span class="ind"></span><a href="//mobile.slashdot.org/comments.pl?sid=11073031&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55139715">2 replies</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_55139773" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55139773" class="commentstatus"></div>
<div id="comment_55139773" class="cw">
</div>

<div id="replyto_55139773"></div>

<ul id="group_55139773">
	<li id="hiddens_55139773" class="hide"></li>
</ul>

</li><li id="tree_55139793" class="comment full contain"><span class="ind"></span>
<div id="comment_status_55139793" class="commentstatus"></div>
<div id="comment_55139793" class="cw">
	<div id="comment_top_55139793" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55139793" name="comment_link_55139793" href="//mobile.slashdot.org/comments.pl?sid=11073031&amp;cid=55139793" onclick="return D2.setFocusComment(55139793)" >AnyvAttack</a>


		 	<span id="comment_score_55139793" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55139793); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~aglider">aglider</a>  <span class="uid"><a href="//slashdot.org/~aglider">( 2435074 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55139793">		
		on Tuesday September 05, 2017 @03:49AM (<span class="ind"></span><a href="//mobile.slashdot.org/comments.pl?sid=11073031&amp;cid=55139793">#55139793</a>)
		<small><a href="http://upload.wikimedia.org/wikipedia/commons/9/96/Animated_glider_emblem.gif" title="http://upload.wikimedia.org/wikipedia/commons/9/96/Animated_glider_emblem.gif" class="user_homepage_display">Homepage</a> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55139793"><p>Once you break into the boot process you can launch any type of attack and perform any type of action.<br>From replacing firmware and recovery code to whatever else you can imagine.<br>Even install a better custom ROM.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55139793">
<span class="ind"></span><a id="reply_link_55139793" class="btn link" href="//mobile.slashdot.org/comments.pl?sid=11073031&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=55139793" onclick="D2.replyTo(55139793); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="AnyvAttack by aglider @slashdot" data-url="https://mobile.slashdot.org/comments.pl?sid=11073031&cid=55139793" data-title="AnyvAttack">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="AnyvAttack by aglider" data-url="https://mobile.slashdot.org/comments.pl?sid=11073031&cid=55139793" data-title="AnyvAttack">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="AnyvAttack by aglider" data-url="https://mobile.slashdot.org/comments.pl?sid=11073031&cid=55139793" data-title="AnyvAttack">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://mobile.slashdot.org/comments.pl?sid=11073031%26cid=55139793" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_55139793" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//mobile.slashdot.org/comments.pl?sid=11073031&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=55139793" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_55139793"></div>

<ul id="group_55139793">
	<li id="hiddens_55139793" class="hide"></li>
</ul>

</li><li id="tree_55139795" class="comment full contain"><span class="ind"></span>
<div id="comment_status_55139795" class="commentstatus"></div>
<div id="comment_55139795" class="cw">
	<div id="comment_top_55139795" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55139795" name="comment_link_55139795" href="//mobile.slashdot.org/comments.pl?sid=11073031&amp;cid=55139795" onclick="return D2.setFocusComment(55139795)" >From what manufacturers do to your phones</a>


		 	<span id="comment_score_55139795" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55139795); return false"><span class=opt>Score:</span>5</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~lwmv">lwmv</a>  <span class="uid"><a href="//slashdot.org/~lwmv">( 2712755 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55139795">		
		on Tuesday September 05, 2017 @03:52AM (<span class="ind"></span><a href="//mobile.slashdot.org/comments.pl?sid=11073031&amp;cid=55139795">#55139795</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55139795">you can see the future of IoT. Tons of phones will never get any security updates. I don't think IoT manufacturers will do better than that. Internet of Things = Internet of Vulnerabilities.</div>
	</div>

	<div class="commentSub" id="comment_sub_55139795">
<span class="ind"></span><a id="reply_link_55139795" class="btn link" href="//mobile.slashdot.org/comments.pl?sid=11073031&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=55139795" onclick="D2.replyTo(55139795); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="From what manufacturers do to your phones by lwmv @slashdot" data-url="https://mobile.slashdot.org/comments.pl?sid=11073031&cid=55139795" data-title="From what manufacturers do to your phones">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="From what manufacturers do to your phones by lwmv" data-url="https://mobile.slashdot.org/comments.pl?sid=11073031&cid=55139795" data-title="From what manufacturers do to your phones">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="From what manufacturers do to your phones by lwmv" data-url="https://mobile.slashdot.org/comments.pl?sid=11073031&cid=55139795" data-title="From what manufacturers do to your phones">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://mobile.slashdot.org/comments.pl?sid=11073031%26cid=55139795" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_55139795" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//mobile.slashdot.org/comments.pl?sid=11073031&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=55139795" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_55139795"></div>

<ul id="group_55139795">
	<li id="hiddens_55139795" class="hide"></li>
</ul>

<ul id="commtree_55139795"><li id="tree_55139895" class="comment full contain"><span class="ind"></span>
<div id="comment_status_55139895" class="commentstatus"></div>
<div id="comment_55139895" class="cw">
	<div id="comment_top_55139895" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55139895" name="comment_link_55139895" href="//mobile.slashdot.org/comments.pl?sid=11073031&amp;cid=55139895" onclick="return D2.setFocusComment(55139895)" >Re:From what manufacturers do to your phones</a>


		 	<span id="comment_score_55139895" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55139895); return false"><span class=opt>Score:</span>4</a>, Funny)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Opportunist">Opportunist</a>  <span class="uid"><a href="//slashdot.org/~Opportunist">( 166417 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55139895">		
		on Tuesday September 05, 2017 @05:01AM (<span class="ind"></span><a href="//mobile.slashdot.org/comments.pl?sid=11073031&amp;cid=55139895">#55139895</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55139895"><p>The Intelligently Designed Internet Of Things Systems are made for their acronym.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55139895">
<span class="ind"></span><a id="reply_link_55139895" class="btn link" href="//mobile.slashdot.org/comments.pl?sid=11073031&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=55139895" onclick="D2.replyTo(55139895); return false;">Reply to This</a> <span class="ind"></span><a class="btn link" href="//mobile.slashdot.org/comments.pl?sid=11073031&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;cid=55139795" onclick="return D2.selectParent(55139795)">Parent</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Re:From what manufacturers do to your phones by Opportunist @slashdot" data-url="https://mobile.slashdot.org/comments.pl?sid=11073031&cid=55139895" data-title="Re:From what manufacturers do to your phones">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Re:From what manufacturers do to your phones by Opportunist" data-url="https://mobile.slashdot.org/comments.pl?sid=11073031&cid=55139895" data-title="Re:From what manufacturers do to your phones">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Re:From what manufacturers do to your phones by Opportunist" data-url="https://mobile.slashdot.org/comments.pl?sid=11073031&cid=55139895" data-title="Re:From what manufacturers do to your phones">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://mobile.slashdot.org/comments.pl?sid=11073031%26cid=55139895" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_55139895" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//mobile.slashdot.org/comments.pl?sid=11073031&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=55139895" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_55139895"></div>

<ul id="group_55139895">
	<li id="hiddens_55139895" class="hide"></li>
</ul>

</li><li id="tree_55140183" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55140183" class="commentstatus"></div>
<div id="comment_55140183" class="cw">
	<div id="comment_top_55140183" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55140183" name="comment_link_55140183" href="//mobile.slashdot.org/comments.pl?sid=11073031&amp;cid=55140183" onclick="return D2.setFocusComment(55140183)" >Re: From what manufacturers do to your phones</a>


		 	<span id="comment_score_55140183" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55140183); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~that+this+is+not+und">that this is not und</a>  <span class="uid"><a href="//slashdot.org/~that+this+is+not+und">( 1026860 )</a></span></a> <a href="/faq/subscriptions.shtml#subscription_other_advantages">*</a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55140183"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55140183"><p>The future of IoT is the NAT servers (or equivalent replacement) with aggressive filtering that will be installed at every access point that IoT devices connect to the internet through. The security will NOT be maintained at the endpoints much longer. Local device of security is the responsibility of the end user, anywhere the user determines that it matter . Smart lightbulbs will have very little autonomy unless somebody explicitly punches through the security layer. Without augmented security added, cheap<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_55140183">

</div>
</div>

<div id="replyto_55140183"></div>

<ul id="group_55140183">
	<li id="hiddens_55140183" class="hide"></li>
</ul>

</li><li id="tree_55140971" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55140971" class="commentstatus"></div>
<div id="comment_55140971" class="cw">
</div>

<div id="replyto_55140971"></div>

<ul id="group_55140971">
	<li id="hiddens_55140971" class="hide"></li>
</ul>

</li><li id="hidestring_55139795"><noscript><b class='more'><span class="ind"></span><a href="//mobile.slashdot.org/comments.pl?sid=11073031&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55139795">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_55139801" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55139801" class="commentstatus"></div>
<div id="comment_55139801" class="cw">
</div>

<div id="replyto_55139801"></div>

<ul id="group_55139801">
	<li id="hiddens_55139801" class="hide"></li>
</ul>

<ul id="commtree_55139801"><li id="tree_55140145" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55140145" class="commentstatus"></div>
<div id="comment_55140145" class="cw">
</div>

<div id="replyto_55140145"></div>

<ul id="group_55140145">
	<li id="hiddens_55140145" class="hide"></li>
</ul>

<ul id="commtree_55140145"><li id="tree_55140325" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55140325" class="commentstatus"></div>
<div id="comment_55140325" class="cw">
	<div id="comment_top_55140325" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55140325" name="comment_link_55140325" href="//mobile.slashdot.org/comments.pl?sid=11073031&amp;cid=55140325" onclick="return D2.setFocusComment(55140325)" >Re:</a>


		 	<span id="comment_score_55140325" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55140325); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~that+this+is+not+und">that this is not und</a>  <span class="uid"><a href="//slashdot.org/~that+this+is+not+und">( 1026860 )</a></span></a> <a href="/faq/subscriptions.shtml#subscription_other_advantages">*</a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55140325"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55140325"><p>Go hang out at the 9600 website.  You can come back when you've memorized the resistor color code.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55140325">

</div>
</div>

<div id="replyto_55140325"></div>

<ul id="group_55140325">
	<li id="hiddens_55140325" class="hide"></li>
</ul>

</li></ul></li><li id="tree_55140497" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55140497" class="commentstatus"></div>
<div id="comment_55140497" class="cw">
	<div id="comment_top_55140497" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55140497" name="comment_link_55140497" href="//mobile.slashdot.org/comments.pl?sid=11073031&amp;cid=55140497" onclick="return D2.setFocusComment(55140497)" >Boot verification</a>


		 	<span id="comment_score_55140497" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55140497); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~tepples">tepples</a>  <span class="uid"><a href="//slashdot.org/~tepples">( 727027 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55140497"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55140497"><p>You think the boot process is as follows:<br>1. Use memcpy to move the OS and application from ROM to RAM<br>2. Jump to the RAM start address</p><p>This is not the case. In fact, the boot process is more similar to the following:<br>1. Use memcpy to move the OS and application from ROM to RAM<br>2. Calculate the hash value of the OS and application<br>3. Decrypt the previously stored hash value of the OS and application using the OS publisher's hardcoded public key<br>4. If the hash values differ, hang<br>5. Jump to the RAM start address</p><p>The<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_55140497">

</div>
</div>

<div id="replyto_55140497"></div>

<ul id="group_55140497">
	<li id="hiddens_55140497" class="hide"></li>
</ul>

<ul id="commtree_55140497"><li id="tree_55140687" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55140687" class="commentstatus"></div>
<div id="comment_55140687" class="cw">
</div>

<div id="replyto_55140687"></div>

<ul id="group_55140687">
	<li id="hiddens_55140687" class="hide"></li>
</ul>

</li><li id="hidestring_55140497"><noscript><b class='more'><span class="ind"></span><a href="//mobile.slashdot.org/comments.pl?sid=11073031&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55140497">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="hidestring_55139801"><noscript><b class='more'><span class="ind"></span><a href="//mobile.slashdot.org/comments.pl?sid=11073031&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55139801">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_55139849" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55139849" class="commentstatus"></div>
<div id="comment_55139849" class="cw">
	<div id="comment_top_55139849" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55139849" name="comment_link_55139849" href="//mobile.slashdot.org/comments.pl?sid=11073031&amp;cid=55139849" onclick="return D2.setFocusComment(55139849)" >More like...</a>


		 	<span id="comment_score_55139849" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55139849); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span>Anonymous Coward</span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55139849"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55139849"><p>More like Chain of No Trust! Am I right, guys?!</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55139849">

</div>
</div>

<div id="replyto_55139849"></div>

<ul id="group_55139849">
	<li id="hiddens_55139849" class="hide"></li>
</ul>

</li><li id="tree_55139901" class="comment full contain"><span class="ind"></span>
<div id="comment_status_55139901" class="commentstatus"></div>
<div id="comment_55139901" class="cw">
	<div id="comment_top_55139901" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55139901" name="comment_link_55139901" href="//mobile.slashdot.org/comments.pl?sid=11073031&amp;cid=55139901" onclick="return D2.setFocusComment(55139901)" >Chain of Trust?</a>


		 	<span id="comment_score_55139901" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55139901); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Opportunist">Opportunist</a>  <span class="uid"><a href="//slashdot.org/~Opportunist">( 166417 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55139901">		
		on Tuesday September 05, 2017 @05:03AM (<span class="ind"></span><a href="//mobile.slashdot.org/comments.pl?sid=11073031&amp;cid=55139901">#55139901</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55139901"><p>I have this mental image of a noose around my neck and someone yanking the attached chain. I think they mean that chain of trust? Trusting the chain to keep the user in reign?</p><p>It's a chain of treachery. If anything, this is GOOD news. It may allow people to actually own their devices, at least for a while.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55139901">
<span class="ind"></span><a id="reply_link_55139901" class="btn link" href="//mobile.slashdot.org/comments.pl?sid=11073031&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=55139901" onclick="D2.replyTo(55139901); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Chain of Trust? by Opportunist @slashdot" data-url="https://mobile.slashdot.org/comments.pl?sid=11073031&cid=55139901" data-title="Chain of Trust?">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Chain of Trust? by Opportunist" data-url="https://mobile.slashdot.org/comments.pl?sid=11073031&cid=55139901" data-title="Chain of Trust?">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Chain of Trust? by Opportunist" data-url="https://mobile.slashdot.org/comments.pl?sid=11073031&cid=55139901" data-title="Chain of Trust?">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://mobile.slashdot.org/comments.pl?sid=11073031%26cid=55139901" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_55139901" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//mobile.slashdot.org/comments.pl?sid=11073031&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=55139901" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_55139901"></div>

<ul id="group_55139901">
	<li id="hiddens_55139901" class="hide"></li>
</ul>

<ul id="commtree_55139901"><li id="tree_55139905" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55139905" class="commentstatus"></div>
<div id="comment_55139905" class="cw">
</div>

<div id="replyto_55139905"></div>

<ul id="group_55139905">
	<li id="hiddens_55139905" class="hide"></li>
</ul>

<ul id="commtree_55139905"><li id="tree_55140021" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55140021" class="commentstatus"></div>
<div id="comment_55140021" class="cw">
	<div id="comment_top_55140021" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55140021" name="comment_link_55140021" href="//mobile.slashdot.org/comments.pl?sid=11073031&amp;cid=55140021" onclick="return D2.setFocusComment(55140021)" >Re:</a>


		 	<span id="comment_score_55140021" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55140021); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Opportunist">Opportunist</a>  <span class="uid"><a href="//slashdot.org/~Opportunist">( 166417 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55140021"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55140021"><p>I thought that was the chain of command?</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55140021">

</div>
</div>

<div id="replyto_55140021"></div>

<ul id="group_55140021">
	<li id="hiddens_55140021" class="hide"></li>
</ul>

</li></ul></li><li id="tree_55140151" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55140151" class="commentstatus"></div>
<div id="comment_55140151" class="cw">
</div>

<div id="replyto_55140151"></div>

<ul id="group_55140151">
	<li id="hiddens_55140151" class="hide"></li>
</ul>

<ul id="commtree_55140151"><li id="tree_55140231" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55140231" class="commentstatus"></div>
<div id="comment_55140231" class="cw">
	<div id="comment_top_55140231" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55140231" name="comment_link_55140231" href="//mobile.slashdot.org/comments.pl?sid=11073031&amp;cid=55140231" onclick="return D2.setFocusComment(55140231)" >Re:</a>


		 	<span id="comment_score_55140231" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55140231); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Opportunist">Opportunist</a>  <span class="uid"><a href="//slashdot.org/~Opportunist">( 166417 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55140231"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55140231"><p>Yes, this MAY allow someone to own your device, but it MAY also allow you to own it.</p><p>Without, you MAY NOT own your own device, but someone else DOES own it with absolute certainty.</p><p>You see the difference, I guess?</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55140231">

</div>
</div>

<div id="replyto_55140231"></div>

<ul id="group_55140231">
	<li id="hiddens_55140231" class="hide"></li>
</ul>

<ul id="commtree_55140231"><li id="tree_55140331" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55140331" class="commentstatus"></div>
<div id="comment_55140331" class="cw">
</div>

<div id="replyto_55140331"></div>

<ul id="group_55140331">
	<li id="hiddens_55140331" class="hide"></li>
</ul>

</li><li id="hidestring_55140231"><noscript><b class='more'><span class="ind"></span><a href="//mobile.slashdot.org/comments.pl?sid=11073031&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55140231">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li></ul></li><li id="tree_55140783" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55140783" class="commentstatus"></div>
<div id="comment_55140783" class="cw">
	<div id="comment_top_55140783" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55140783" name="comment_link_55140783" href="//mobile.slashdot.org/comments.pl?sid=11073031&amp;cid=55140783" onclick="return D2.setFocusComment(55140783)" >Re:</a>


		 	<span id="comment_score_55140783" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55140783); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~thegarbz">thegarbz</a>  <span class="uid"><a href="//slashdot.org/~thegarbz">( 1787294 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55140783"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55140783"><p><div class="quote"><p>It may allow people to actually own their devices</p></div><p>The problem is it also allows people to own *other's* devices.</p><p>The fundamental problem with this is by owning your device you are leaving a security vulnerability exposed. In many cases a cure worse than the disease.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55140783">

</div>
</div>

<div id="replyto_55140783"></div>

<ul id="group_55140783">
	<li id="hiddens_55140783" class="hide"></li>
</ul>

</li><li id="hidestring_55139901"><noscript><b class='more'><span class="ind"></span><a href="//mobile.slashdot.org/comments.pl?sid=11073031&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55139901">2 replies</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_55139937" class="comment full contain"><span class="ind"></span>
<div id="comment_status_55139937" class="commentstatus"></div>
<div id="comment_55139937" class="cw">
	<div id="comment_top_55139937" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55139937" name="comment_link_55139937" href="//mobile.slashdot.org/comments.pl?sid=11073031&amp;cid=55139937" onclick="return D2.setFocusComment(55139937)" >More links</a>


		 	<span id="comment_score_55139937" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55139937); return false"><span class=opt>Score:</span>5</a>, Informative)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~eulernet">eulernet</a>  <span class="uid"><a href="//slashdot.org/~eulernet">( 1132389 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55139937">		
		on Tuesday September 05, 2017 @05:25AM (<span class="ind"></span><a href="//mobile.slashdot.org/comments.pl?sid=11073031&amp;cid=55139937">#55139937</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55139937"><p>BootStomp's code:<br><a href="https://github.com/ucsb-seclab/BootStomp" title="github.com">https://github.com/ucsb-seclab...</a> [github.com]</p><p>UCSB's team site:<br><a href="https://seclab.cs.ucsb.edu/academic/publishing/" title="ucsb.edu">https://seclab.cs.ucsb.edu/aca...</a> [ucsb.edu]</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55139937">
<span class="ind"></span><a id="reply_link_55139937" class="btn link" href="//mobile.slashdot.org/comments.pl?sid=11073031&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=55139937" onclick="D2.replyTo(55139937); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="More links by eulernet @slashdot" data-url="https://mobile.slashdot.org/comments.pl?sid=11073031&cid=55139937" data-title="More links">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="More links by eulernet" data-url="https://mobile.slashdot.org/comments.pl?sid=11073031&cid=55139937" data-title="More links">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="More links by eulernet" data-url="https://mobile.slashdot.org/comments.pl?sid=11073031&cid=55139937" data-title="More links">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://mobile.slashdot.org/comments.pl?sid=11073031%26cid=55139937" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_55139937" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//mobile.slashdot.org/comments.pl?sid=11073031&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=55139937" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_55139937"></div>

<ul id="group_55139937">
	<li id="hiddens_55139937" class="hide"></li>
</ul>

<ul id="commtree_55139937"><li id="tree_55140977" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55140977" class="commentstatus"></div>
<div id="comment_55140977" class="cw">
</div>

<div id="replyto_55140977"></div>

<ul id="group_55140977">
	<li id="hiddens_55140977" class="hide"></li>
</ul>

</li><li id="hidestring_55139937"><noscript><b class='more'><span class="ind"></span><a href="//mobile.slashdot.org/comments.pl?sid=11073031&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55139937">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_55139957" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55139957" class="commentstatus"></div>
<div id="comment_55139957" class="cw">
</div>

<div id="replyto_55139957"></div>

<ul id="group_55139957">
	<li id="hiddens_55139957" class="hide"></li>
</ul>

<ul id="commtree_55139957"><li id="tree_55140095" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55140095" class="commentstatus"></div>
<div id="comment_55140095" class="cw">
	<div id="comment_top_55140095" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55140095" name="comment_link_55140095" href="//mobile.slashdot.org/comments.pl?sid=11073031&amp;cid=55140095" onclick="return D2.setFocusComment(55140095)" >Re:</a>


		 	<span id="comment_score_55140095" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55140095); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Zero__Kelvin">Zero__Kelvin</a>  <span class="uid"><a href="//slashdot.org/~Zero__Kelvin">( 151819 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55140095"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55140095">3 of the 4 don't come from China. NVIDIA and Qualcomm are US companies and Mediatek is based in Taiwan.</div>
	</div>

	<div class="commentSub" id="comment_sub_55140095">

</div>
</div>

<div id="replyto_55140095"></div>

<ul id="group_55140095">
	<li id="hiddens_55140095" class="hide"></li>
</ul>

<ul id="commtree_55140095"><li id="tree_55140165" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55140165" class="commentstatus"></div>
<div id="comment_55140165" class="cw">
</div>

<div id="replyto_55140165"></div>

<ul id="group_55140165">
	<li id="hiddens_55140165" class="hide"></li>
</ul>

</li><li id="tree_55140511" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55140511" class="commentstatus"></div>
<div id="comment_55140511" class="cw">
	<div id="comment_top_55140511" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55140511" name="comment_link_55140511" href="//mobile.slashdot.org/comments.pl?sid=11073031&amp;cid=55140511" onclick="return D2.setFocusComment(55140511)" >Taiwan vs. Hong Kong</a>


		 	<span id="comment_score_55140511" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55140511); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~tepples">tepples</a>  <span class="uid"><a href="//slashdot.org/~tepples">( 727027 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55140511"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55140511"><p><div class="quote"><p>3 of the 4 don't come from China. NVIDIA and Qualcomm are US companies and Mediatek is based in Taiwan.</p></div><p>To what extent does Taiwan, Republic of China, have more practical autonomy from the PRC than, say, Hong Kong SAR?</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55140511">

</div>
</div>

<div id="replyto_55140511"></div>

<ul id="group_55140511">
	<li id="hiddens_55140511" class="hide"></li>
</ul>

</li><li id="hidestring_55140095"><noscript><b class='more'><span class="ind"></span><a href="//mobile.slashdot.org/comments.pl?sid=11073031&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55140095">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li></ul></li><li id="tree_55140047" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55140047" class="commentstatus"></div>
<div id="comment_55140047" class="cw">
	<div id="comment_top_55140047" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55140047" name="comment_link_55140047" href="//mobile.slashdot.org/comments.pl?sid=11073031&amp;cid=55140047" onclick="return D2.setFocusComment(55140047)" >solution?</a>


		 	<span id="comment_score_55140047" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55140047); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span>Anonymous Coward</span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55140047"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55140047"><p>Don't ever reboot your phone?</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55140047">

</div>
</div>

<div id="replyto_55140047"></div>

<ul id="group_55140047">
	<li id="hiddens_55140047" class="hide"></li>
</ul>

</li><li id="tree_55140261" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55140261" class="commentstatus"></div>
<div id="comment_55140261" class="cw">
</div>

<div id="replyto_55140261"></div>

<ul id="group_55140261">
	<li id="hiddens_55140261" class="hide"></li>
</ul>

</li><li id="tree_55140365" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55140365" class="commentstatus"></div>
<div id="comment_55140365" class="cw">
</div>

<div id="replyto_55140365"></div>

<ul id="group_55140365">
	<li id="hiddens_55140365" class="hide"></li>
</ul>

</li><li id="tree_55140945" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55140945" class="commentstatus"></div>
<div id="comment_55140945" class="cw">
	<div id="comment_top_55140945" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55140945" name="comment_link_55140945" href="//mobile.slashdot.org/comments.pl?sid=11073031&amp;cid=55140945" onclick="return D2.setFocusComment(55140945)" >Don't you mean?</a>


		 	<span id="comment_score_55140945" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55140945); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~BradleyUffner">BradleyUffner</a>  <span class="uid"><a href="//slashdot.org/~BradleyUffner">( 103496 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55140945"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55140945"><blockquote><div><p> "Some of these vulnerabilities would allow an attacker to execute arbitrary code as part of the bootloader (thus compromising the entire chain of trust), or to perform permanent denial-of-service attacks," the research team said (PDF)"</p></div></blockquote><p>I think they actually mean:<br>Some of these vulnerabilities would allow a user to execute arbitrary code as part of the bootloader (thus allowing users to have some control over their devices), or to perform installations of custom Android versions with better security than the<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_55140945">

</div>
</div>

<div id="replyto_55140945"></div>

<ul id="group_55140945">
	<li id="hiddens_55140945" class="hide"></li>
</ul>

</li><li id="hidestring_0"><noscript><b class='more'><span class="ind"></span><a href="//mobile.slashdot.org/comments.pl?sid=11073031&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=0">8 replies</a> beneath your current threshold.</b></noscript></li>
			<li id="roothiddens" class="hide"></li>
		</ul>
	
	
	
	

<noscript><p><b>There may be more comments in this discussion. Without JavaScript enabled, you might want to <a href="//mobile.slashdot.org/users.pl?op=editcomm">turn on Classic Discussion System</a> in your preferences instead.</b></p></noscript>
<div id="discussion_buttons" class="clearfix">






</div>


<div class="newcmnt"><div id="replyto_0"></div></div>


	<script type="text/javascript">
<!--
		D2.currents()['hidden']   = 27;
		D2.currents()['full']     = 8;
		D2.currents()['oneline']  = 26;
		// D2.currents_total(61);

		D2.abbrev_comments({55140559:644,55140183:515,55140945:561,55140309:615,55140683:522,55140497:556});
		D2.noshow_comments([55139725,55139729,55140033,55139921,55139829,55140529,55140551,55139665,55140013,55140557,55139667,55139715,55139719,55139999,55139773,55140971,55139801,55140145,55140687,55139905,55140151,55140331,55140977,55139957,55140165,55140261,55140365]);
		D2.pieces_comments([55140223,55140309,55140683,55140941,55141031,55139887,55140559,55139913,55139695,55140155,55140789,55139709,55140339,55139891,55140161,55140183,55140325,55140497,55139849,55140021,55140231,55140783,55140095,55140511,55140047,55140945]);
		D2.init_hiddens([55139889,55139729,55139661,55140013,55139665,55139715,55139795,55140497,55139801,55140231,55139901,55139937,55140095,0]);

		D2.finishLoading();


		if (D2.thresh_totals()[6][6][1] == 0) {
			D2.replyTo(0, 1);
		}


//-->
	</script>


</div>



	
	
		<div id="clickgen" class="grid_24 b">
    <section class="grid_16 f">
        <div>
			<h4 class="nobg">
			    <a href="" class="selected btmrel" onClick="getRelatedStoriesForStory(330841);return false">Related Links</a>
			    <span class="tops fright">Top of the: <a href="" class="btmday" onClick="getTopStories(1);return false">day</a>, <a class="btmweek" href="" onClick="getTopStories(7); return false">week</a>, <a href="" onClick="getTopStories(30);return false" class="btmmonth">month</a>.</span>
			</h4>
			<ul class="nobullets bmrelatedlist">


	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>561<span class="hide"> comments</span></span></span><a href="//mobile.slashdot.org/story/17/07/10/2219215/would-you-buy-the-iphone-8-if-it-cost-1200?sdsrc=popbyskidbtmprev">Would You Buy the iPhone 8 If It Cost $1,200?</a>
	</li>

	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>514<span class="hide"> comments</span></span></span><a href="//mobile.slashdot.org/story/17/02/18/2013247/should-international-travelers-leave-their-phones-at-home?sdsrc=popbyskidbtmprev">Should International Travelers Leave Their Phones At Home?</a>
	</li>

	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>389<span class="hide"> comments</span></span></span><a href="//mobile.slashdot.org/story/17/06/19/0415243/a-colorado-group-wants-to-ban-smartphones-for-kids?sdsrc=popbyskidbtmprev">A Colorado Group Wants To Ban Smartphones For Kids</a>
	</li>

	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>330<span class="hide"> comments</span></span></span><a href="//mobile.slashdot.org/story/17/08/03/1953246/slashdot-asks-have-smartphones-destroyed-a-generation?sdsrc=popbyskidbtmprev">Slashdot Asks: Have Smartphones Destroyed a Generation?</a>
	</li>

	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>311<span class="hide"> comments</span></span></span><a href="//mobile.slashdot.org/story/16/09/09/2054207/apple-removed-headphone-jack-from-new-iphones-because-it-owns-largest-bluetooth-headphone-company?sdsrc=popbyskidbtmprev">Apple Removed Headphone Jack From New iPhones Because It Owns Largest Bluetooth Headphone Company</a>
	</li>


</ul>
        </div>
    </section>
    <aside class="grid_8 st">
		<section class="grid_24 f">
			<div>
				<h5 class="tlnav"><a href="//tech.slashdot.org/story/17/09/05/1014235/android-one-is-anything-but-dead-google-reaffirms-with-xiaomi-mi-a1?sdsrc=nextbtmnext">next</a></h5>
				<div class="grid_24">
	    
	    
            	 <span class="grid_7 tcenter"><img src="//a.fsdn.com/sd/topics/google_64.png" width="64" height="64" alt="Google"></span>
	    
					<p class="grid_12"><a href="//tech.slashdot.org/story/17/09/05/1014235/android-one-is-anything-but-dead-google-reaffirms-with-xiaomi-mi-a1?sdsrc=nextbtmprev">Android One Is Anything But Dead, Google Reaffirms With Xiaomi Mi A1 </a></p>
					<span class="grid_5 tcenter comments"><span class="cmntcnt_large fleft"><span class="slant"></span><span>69<span class="hide"> comments</span></span></span></span>
	
				</div>
			</div>
		</section>
		<section class="grid_24">
			<div>
				<h5 class="tlnav"><a href="//tech.slashdot.org/story/17/09/04/2124221/oracle-staff-report-big-layoffs-across-solaris-sparc-teams?sdsrc=prevbtmprev">previous</a></h5>
				<div class="grid_24">
	    
            	 <span class="grid_7 tcenter"><img src="//a.fsdn.com/sd/topics/business_64.png" width="64" height="64" alt="Businesses"></span>
	    
					<p class="grid_12"><a href="//tech.slashdot.org/story/17/09/04/2124221/oracle-staff-report-big-layoffs-across-solaris-sparc-teams?sdsrc=prevbtmprev">Oracle Staff Report Big Layoffs Across Solaris, SPARC Teams</a></p>

					<span class="grid_5 tcenter comments"><span class="cmntcnt_large fleft"><span class="slant"></span><span>176<span class="hide"> comments</span></span></span></span>
				</div>
			</div>
		</section>
	</aside>
</div>
		<div id="taboola-below-article-text-links"></div>
<script type="text/javascript">
	window._taboola = window._taboola || [];
	_taboola.push({
		mode: 'text-links-a',
		container: 'taboola-below-article-text-links',
		placement: 'Below Article Text Links',
		target_type: 'mix'
});
</script>
	

</section>
			</div>
		</div>
		<div class="row top-space">


			<div class="grid_24">
				<!-- 728px ad -->

				<div class="adwrap">
<div id='div-gpt-ad-728x90_c'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-728x90_c');});</script></div>
</div>
				<!-- end 728px ad -->
				<!-- Slashdot Deals 6 Best Sellers -->
					<div class="row deals-footer">
						<div class="units-8 indent-2 deals-wrapper">
						  <div class="deals-header"><h1>Slashdot Top Deals</h1></div>
						  <div id="deals-output">
							<script id="deals-template" type="text/x-handlebars-template">
							  {{#each deal}}
								<div class="deal">
								  <a href="{{urlPath permalink}}?&utm_source=slashdot.org&utm_medium=dealfeed-footerfeed&utm_campaign={{slug}}" target="_blank">
								  	<img src="{{main_image}}" alt="" />
								  </a>
								  <p class="title"><a href="{{urlPath permalink}}?&utm_source=slashdot.org&utm_medium=dealfeed-footerfeed&utm_campaign={{slug}}" target="_blank">{{title}}</a></p>
								  <p class="deal-price">{{centConversion price_in_cents}}</p>
								</div>
							  {{/each}}
							</script>
						  </div>
						</div>
					</div>
					<script>
						if ( isAdBlockActive ) {
							$.getScript( "//a.fsdn.com/sd/js/scripts/min/deals-min.js", function(){
								runDealsWidget();
							});
						}
					</script>

					<!-- End Slashdot Deals 6 Best Sellers -->
				</div>
			</div>
		</div>
	</div>
	<!-- SMACKS: END COMMENTS SECTION -->
</div>
<!-- SMACKS: END COMMENTS CONTAINER -->


	

<script type="text/javascript">

$(function(){
$('#firehose-filter').
	focus(function(event){
		gFocusedText = this;
	}).
	blur(function(event){
		if ( gFocusedText === this ) {
			gFocusedText = null;
		}
	});


apply_updates_when(		'at-end', true);
});
</script>


<!-- body end --><!-- footer type=current begin -->
	
	</section>
	
	


	<footer id="fhft" class="grid_24 nf aoc">
		<div id="logo_nf" class="fleft">
			<a href="//slashdot.org"><span>Slashdot</span></a>
		</div>
		<nav role="firehose footer">
			
				
				
				
				

				
						<span class="ind"></span><a class="btn first" href="//mobile.slashdot.org/comments.pl?sid=11073031&amp;op=reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=" onclick="D2.replyTo(0); return false;">Post</a>
				
				<a class="btn hide" id="footer_moderate_button">Moderate</a>
				<a class="btn hide" id="footer_moderatorhelp_button">Moderator Help</a>
				<a class="btn hide" id="footer_delete_button" title="Checked comments will be deleted.">Delete</a>
				<script>
					(function($){
						var old_moderate_btn = $("#discussion_moderate_button");
						if (old_moderate_btn.length) {
							var moderate_btn = $("#footer_moderate_button");
							moderate_btn.click(
								function(){old_moderate_btn.click()}
							);
							moderate_btn.removeClass('hide');
						}

						var old_moderatorhelp_btn = $("#discussion_moderatorhelp_button");
						if (old_moderatorhelp_btn.length) {
							var moderatorhelp_btn = $("#footer_moderatorhelp_button");
							moderatorhelp_btn.click(
								function(){old_moderatorhelp_btn.click()}
							);
							moderatorhelp_btn.attr(
								'href', old_moderatorhelp_btn.attr('href')
							);
							moderatorhelp_btn.removeClass('hide');
						}

						var old_delete_btn = $("#discussion_delete_button");
						if (old_delete_btn.length) {
							var delete_btn = $("#footer_delete_button");
							delete_btn.click(
								function(){old_delete_btn.click()}
							);
							delete_btn.removeClass('hide');
						}

						$('#discussion_buttons').addClass('hide');
					})(Slash.jQuery); // (function($){
				</script>
				<ul class="fleft">
					
						<li class="fleft selected">
							<span class="nbutton btn hide link reset" id="more_comments_button">
								<a href="#" onclick="D2.ajaxFetchComments(0,1); return false">
									<span id="more_comments_num_a" class="hide">Get more comments</span>
								</a>
							</span>
						</li>
					
					
						<li class="fleft">
							<span class="loadedcommentcnt">56</span> of <span class="totalcommentcnt">56</span> loaded
						</li>
					
				</ul>
				
					<script type="text/javascript">D2.finishLoading()</script>
				
			

			
			<ul class="fright submitstory">
					<li class="fright">
						<a href="/submit">Submit<span class="opt"> Story</span></a>
					</li>
			</ul>
		</nav>
		


	</footer>
	<section class="bq">
		<blockquote class="msg grid_24" cite="https://slashdot.org">
			<p>/usr/news/gotcha</p>
			<span class="slant"></span>
		</blockquote>
	</section>
	<footer id="ft" class="grid_24">
		<nav class="grid_10" role="footer">
			<ul>
				<li><a href="//slashdot.org/faq">FAQ</a></li>
				<li><a href="//slashdot.org/archive.pl">Story Archive</a></li>
				<li><a href="//slashdot.org/hof.shtml">Hall of Fame</a></li>
				<li><a href="http://slashdotmedia.com/advertising-and-marketing-services/">Advertising</a></li>
				<li><a href="http://slashdotmedia.com/terms-of-use/">Terms</a></li>
				<li><a href="http://slashdotmedia.com/privacy-statement/">Privacy</a></li>
				<li id="teconsent"></li>
				<li><a href="http://slashdotmedia.com/opt-out-choices/">Opt Out Choices</a></li>
				<li><a href="//slashdot.org/faq/slashmeta.shtml">About</a></li>
				<li><a href="mailto:feedback@slashdot.org">Feedback</a></li>
				<li><a href="#" onclick="set_mobile_pref('mobile',1);return false;">Mobile View</a></li>
				<li><a href="//slashdot.org/blog">Blog</a></li>
			</ul>
		</nav>
		<br>
		
		<div class="grid_14 tright tm">Trademarks property of their respective owners. Comments owned by the poster. <span class="nobr">Copyright &copy; 2017 SlashdotMedia. All Rights Reserved.</span></div>
                <script type="text/javascript" src="//consent-st.truste.com/get?name=notice.js&amp;domain=slashdot.org&amp;c=teconsent&amp;text=true"></script>
	</footer>

	
	<div class="overlay"></div>
<div class="modal-box">
    <a href="#" id="close-modal">Close</a>
    <article class="modal-content">
    </article>
    <footer>
</div>




<div id="modal_cover" class="hide" onclick="hide_modal_box(); return false;"></div>
<div id="modal_box" class="hide">
      <div id="modal_box_content"></div>
      <header class="n">
                  <span class="fadeout"></span>
                  <span class="fadeoutfade"></span>
		  <span class="pf"><a class="ico close" onclick="hide_modal_box(); return false;" href="#"><span>Close</span></a></span>
		  <h3 class="pf"><div id="logo"><a href="//slashdot.org">Slashdot</a></div><span id="preference_title"></span></h3>
      </header>
</div>
	
	<!-- CCM Tag -->
<script type="text/javascript">
  (function () {
    /*global _ml:true, window */
    _ml = window._ml || {};
    _ml.eid = '771';

    var s = document.getElementsByTagName('script')[0], cd = new Date(), mltag = document.createElement('script');
    mltag.type = 'text/javascript'; mltag.async = true;
    mltag.src = '//ml314.com/tag.aspx?' + cd.getDate() + cd.getMonth() + cd.getFullYear();
    s.parentNode.insertBefore(mltag, s);
  })();
</script>
<!-- End CCM Tag -->

<script type="text/javascript">
window.google_analytics_uacct = "UA-32013-5";

var _gaq = _gaq || [];





  _gaq.push(['_setAccount', 'UA-36136016-1']);
  _gaq.push(['b._setAccount', 'UA-32013-5']);
  _gaq.push(['_setDomainName', '.slashdot.org']);
  _gaq.push(['b._setDomainName', '.slashdot.org']);

	
		_gaq.push(['_addIgnoredRef', 'slashdot.org']);
		_gaq.push(['b._addIgnoredRef', 'slashdot.org']);
	


  _gaq.push(['_setCustomVar', 1, 'User Type',  'Anon', 3]);
  _gaq.push(['b._setCustomVar', 1, 'User Type',  'Anon', 3]);		
	
	_gaq.push(['_setCustomVar', 2, 'Page','article2', 3]);
	_gaq.push(['b._setCustomVar', 2, 'Page','article2', 3]);

	



// track beta behavior for user
var betamatches = document.cookie.match(/betagroup=(-?\d+)/);

if(betamatches && betamatches[1]) {
  if(betamatches[1] == -1) {
    _gaq.push(['_setCustomVar', 3, 'Beta-Usage','opt-out', 3]);
  } else {
    _gaq.push(['_setCustomVar', 3, 'Beta-Usage','unredirected', 3]);
  }
}



  _gaq.push(['_trackPageview']);
  _gaq.push(['b._trackPageview']);
  _gaq.push(['_trackPageLoadTime']);
  _gaq.push(['b._trackPageLoadTime']);




  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();

</script>

<!-- CCM GA Push -->
<script>
    if (typeof _ml !== 'undefined' && _ml.us) {
        if (_ml.us.tp && _ml.us.tp.length > 0) {
            ga('set', 'dimension2', _ml.us.tp[0]);
        }
        if (_ml.us.pc && _ml.us.pc.length > 0) {
            ga('set', 'dimension7', _ml.us.pc[0]);
        }
        ga('set', 'dimension3', _ml.us.ind);
        ga('set', 'dimension4', _ml.us.cr);
        ga('set', 'dimension5', _ml.us.cs);
        ga('set', 'dimension6', _ml.us.dm);
        ga('set', 'dimension8', _ml.us.sn);
    }
</script>

<!-- Sticky Ads -->
<script type="text/javascript">
var topBannerViewed = false;
if($('#div-gpt-ad-728x90_a').length > 0 && window.outerWidth >= 1070 && !isAdBlockActive){
    $(window).scroll(function(){
        var y = $(document).scrollTop();
        var z =  y + window.outerHeight;
        var navOffset = 0;
        var offset = [
            $('.nav-wrap').outerHeight(true),
            $('.nav-secondary-wrap').outerHeight(true)
        ];
        for(row in offset){
            if(offset[row]) navOffset = navOffset + parseInt(offset[row]);
        }
        $('.adwrap-unviewed').each(function(){
            var cls = 'adwrap-sticky';
            var toggleCls = 'adwrap';
			$('.banner-wrapper').css('height', $('.banner-contain').outerHeight());
            if($(this).hasClass('railad')) {
                if(topBannerViewed){
                    var topPixels = $(this).offset().top;
                    navOffset += $('.adwrap').outerHeight();
                    if(y >= topPixels && y >= navOffset){
                        $('#slashboxes').css('top', 0).css('position','fixed').css('right',13);
                    } else {
                        $('#slashboxes').removeAttr('style');
                    }
                }
                return;
            }
            var topPixels = $(this).offset().top;
            if(y >= topPixels && y >= navOffset){
                $(this).addClass(cls);
                $(this).removeClass('adwrap');
				if(cls == 'adwrap-sticky') { //top banner
                    topBannerViewed = false;
					$('#slashboxes').css('top',$(this).outerHeight() || 0).css('position','fixed').css('right',13);
				}
                if(topBannerViewed) {
                    console.log('hereeee');
					$('#slashboxes').css('top', 0).css('position','fixed').css('right',13);
				}
            }else{
                $(this).removeClass(cls);
                $(this).addClass(toggleCls);
                $('#slashboxes').removeAttr('style');
            }
        });
		if($('.adwrap-viewed-banner').length > 0){
			topBannerViewed = true;
			$('.adwrap-viewed-banner').removeClass('adwrap-unviewed').removeClass('adwrap-sticky').addClass('adwrap');
		}
        if($('.adwrap-viewed-railad').length > 0){
            $('.adwrap-viewed-railad').removeClass('adwrap-unviewed').removeClass('adwrap-railad-sticky');
			$('#slashboxes').removeAttr('style');
		}
    });
}
</script>

<!-- Piwik -->
<script type="text/javascript">
  var _paq = _paq || [];
  _paq.push(["setCookieDomain", "*.slashdot.org"]);
  _paq.push(['trackPageView']);
  _paq.push(['enableLinkTracking']);
  (function() {
    var u="//analytics.slashdotmedia.com/";
    _paq.push(['setTrackerUrl', u+'sd.php']);
    _paq.push(['setSiteId', 40]);
    var d=document, g=d.createElement('script'), s=d.getElementsByTagName('script')[0];
    g.type='text/javascript'; g.async=true; g.defer=true; g.src=u+'sd.js'; s.parentNode.insertBefore(g,s);
  })();
</script>
<noscript><p><img src="//analytics.slashdotmedia.com/sd.php?idsite=40" style="border:0;" alt="" /></p></noscript>

<!-- Sponsored Whitepaper/Documents -->
<script>
    if(window.location.pathname == '/'){
        var nelId = (location.search.split('nel_id=')[1] || '').split('&')[0];
        var url = '/ajax.pl?op=nel';
        if(nelId){
            url += '&nel_id='+nelId;
        }
        $.ajax({
            url: url,
            success: function(html){
                $('#firehoselist article').eq(1).after(html);
            }
        });

        $.ajax({
            url: '/ajax.pl?op=geo',
            success: function(geo){
                var text = "";
                var possible = "ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz";
                for( var i=0; i < 15; i++ )
                        text += possible.charAt(Math.floor(Math.random() * possible.length));
                window.addEventListener('message', receiveMessage, false);
                function receiveMessage(evt){
                    if (evt.data && evt.data.lf_iframeid && evt.data.lf_height) {
                        //resize iframe to fit larger leadgen form
                        document.getElementById(evt.data.lf_iframeid).height = (evt.data.lf_height) + "px";
                    }
                }
                $('#firehoselist article').eq(12).after('<iframe width="100%" height="0" scrolling="no" frameborder="0" id="bz-lf-'+text+'" name="bz-lf-'+text+'" src="//d1o5u7ifbz3swt.cloudfront.net/showcase/index.php?id=dynamic&lp=SD_IMM&country='+geo+'"></iframe>');
            }
        });
    }
</script>

<!-- Datonics -->
<script async type="text/javascript" src="//ads.pro-market.net/ads/scripts/site-143573.js"></script>
	<script id="after-content" type="text/javascript">
(function( $, fn, console ){
	$ && fn && $(function(){ fn($, console); });
})(window.jQuery, window.pageload_done, window.console);
</script>
	
	<script type='text/javascript'>
	if(!document.location.href.match(/source=autorefresh/)) {
		document.write('<img src="//slashdot.org/images/js.gif?378">');
	}
</script>
<noscript>
	<img src="//slashdot.org/images/njs.gif?505">
</noscript>
	<div class="busy genericspinner hide"><span>Working...</span></div>
	<script>
		if(typeof(Storage)!=="undefined"){
			window.scrollTo(0,sessionStorage.scrollPos);
				$(window).scroll(function () {
				//You've scrolled this much:
				sessionStorage.scrollPos = $(window).scrollTop();
			});
		}
		$(function(){
			$('a').click(function(){
				delete sessionStorage.scrollPos;
			})
		});
		// window.onbeforeunload = function () {
		// 	console.log('bakc button clicked');
		// 	delete sessionStorage.scrollPos;
		// }
		window.onpopstate=function() {
			delete sessionStorage.scrollPos;
		}
	</script>
	

	
		<!-- 1x1 story page -->
		<div id='div-gpt-ad-1x1'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-1x1');});</script></div>
	

        <script type="text/javascript">
          window._taboola = window._taboola || [];
          _taboola.push({flush: true}); 
        </script>       

	</body>
	</html>


	<!-- footer type=current end -->